Bug 129640 - anaconda removes old known-good kernel.
anaconda removes old known-good kernel.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-11 06:20 EDT by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 11:34:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2004-08-11 06:20:23 EDT
When upgrading, anaconda removed my old kernel. The new kernel did not
boot due to mkinitrd problems (now fixed).

This is violating the oft-repeated advice to _NEVER_ 'rpm -U' a kernel
package. And it made my system not boot.
Comment 1 Jeremy Katz 2004-08-11 11:34:11 EDT
An anaconda upgrade always has and always will upgrade kernels. 
Userspace is regularly depending on features being present in "new
enough" kernels and leaving an older kernel causes other strange and
unique breakage.

Note You need to log in before you can comment on or make changes to this bug.