Bug 1296419 - Self Service UI gives 404 in 5.5.2.0
Self Service UI gives 404 in 5.5.2.0
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Build (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Satoe Imaishi
Vadim Rutkovsky
: ZStream
: 1296315 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 03:45 EST by Vadim Rutkovsky
Modified: 2016-02-10 10:31 EST (History)
12 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 10:31:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2016-01-07 03:45:30 EST
Description of problem:
Self Service UI cannot be found - page gives 404

Version-Release number of selected component (if applicable):
5.5.20

How reproducible:
Always

Steps to Reproduce:
1. Open http://<appliance ip>/self_service

Actual results:
http 404

Expected results:
Self Service login page is displayed

Additional info:
Works find in 5.5.13
Comment 1 Pavol Kotvan 2016-01-07 04:09:28 EST
It seems self_service web directory is missing on 5.5.20 appliance:

5.5.20:
# ls -ltrd /var/www/miq/vmdb/public/self_service                    
ls: cannot access /var/www/miq/vmdb/public/self_service: No such file or directory

5.5.13:
# ls -ltrd /var/www/miq/vmdb/public/self_service
drwxr-xr-x. 7 root root 80 Dec  4 09:44 /var/www/miq/vmdb/public/self_service
Comment 2 Dan Clarizio 2016-01-07 11:16:07 EST
*** Bug 1296315 has been marked as a duplicate of this bug. ***
Comment 3 Dave Johnson 2016-01-07 13:54:44 EST
Guys, there was some confusion around your build numbers...

it 5.5.2.0, which is where this was seen, and verified to not be present in 5.5.0.13
Comment 4 Satoe Imaishi 2016-01-08 12:39:14 EST
Ran the script that generates the tarball against 5.5.2.0 tag, but the self_service build went fine and the directory exists as expected.

There is no way for me to know what happened during the 5.5.2.0 build at this point.  However, I will update the script(s) so issues like this will be caught properly during the build and error out.
Comment 5 CFME Bot 2016-01-08 15:29:25 EST
New commit detected on cfme_productization/master:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme_productization.git;a=commit;h=968e12e55e9363920f7e828f9d9aeaf0c5b7a4a3

commit 968e12e55e9363920f7e828f9d9aeaf0c5b7a4a3
Merge: 49aad16 ffbf357
Author:     Jason Frey <jfrey@redhat.com>
AuthorDate: Fri Jan 8 15:17:12 2016 -0500
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Fri Jan 8 15:17:12 2016 -0500

    Merge branch 'fix_error_handling' into 'master'
    
     Error executing commands in build:tar should cause build failure
    
    Error out if command execution returns an error in build:tar rake task.
    
    Currently it doesn't exit but continue, and it can cause issues like this:
    https://bugzilla.redhat.com/show_bug.cgi?id=1296419
    
    See merge request !158

 manageiq-appliance-build/lib/tasks/tar_build.rake | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)
Comment 8 Vadim Rutkovsky 2016-01-18 10:11:29 EST
Works on 5.5.2.1
Comment 9 errata-xmlrpc 2016-02-10 10:31:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.