Bug 129644 - Should allow customisation of mkfs options
Summary: Should allow customisation of mkfs options
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-11 12:51 UTC by Stewart Smith
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 17:50:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stewart Smith 2004-08-11 12:51:52 UTC
Related to SELinux inefficiencies on XFS (due to inode size),
sometimes mkfs options need (or are wanted to) be customised.

XFS provides options for things like log size and inode size which can
make a big difference in system performance.

On the 'Modify' screen in Disk Druid, it would be good to be able to
customise these options via the GUI.

Comment 1 Stewart Smith 2004-08-11 12:53:53 UTC
Will help fix:
Default isize of 256 bytes is too small for SE Linux

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120622

Comment 2 Jeremy Katz 2004-08-11 15:36:34 UTC
anaconda is not going to have a text field added that's "insert your
options here".  It's completely and utterly non-intuitive to users. 
ancaonda should be setting the "right" options to begin with (and
arguably, the tools should have the right defaults as well instead of
leaving it to the user to guess and thus get it wrong nine times out
of ten)

If you have explicit requests for modifications to options used, those
can be filed and will be considered on a case by case basis.

Comment 3 Stewart Smith 2004-08-12 13:40:48 UTC
I probably wasn't clear, sorry.

I was meaning to suggest having actual visual fields based on what
options mkfs can take. (i.e. a set of text fields: one for inode size,
one for log size etc).

i agree that one giant text field is wrong, but a set of fields could
be a good idea - especially since there are legitimate reasons to want
to modify some FS parameters.


Comment 4 Jeremy Katz 2004-08-12 17:50:07 UTC
The problem is that these can't really be done generically as
different filesystems have different options.  Even if they didn't,
it's still incredibly obtuse for the user.


Note You need to log in before you can comment on or make changes to this bug.