Bug 1296495 - Rawhide Minimal ARM image from 20160106 is missing initial-setup package
Rawhide Minimal ARM image from 20160106 is missing initial-setup package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
rawhide
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24AlphaBlocker
  Show dependency treegraph
 
Reported: 2016-01-07 06:16 EST by Jan Sedlák
Modified: 2016-01-14 12:46 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 12:46:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2016-01-07 06:16:10 EST
Description of problem:
Rawhide Minimal image from 20160106 for ARM is missing initial-setup package, so user is unable to set root password (and create user) on the first boot. Fedora is booting directly to login screen (instead of initial-setup, as it should have).

Version-Release number of selected component (if applicable):
Fedora 24 Rawhide 20160106, minimal disk raw image

Steps to Reproduce:
1. Download image (from https://kojipkgs.fedoraproject.org/work/tasks/3983/12433983/Fedora-Minimal-armhfp-rawhide-20160106-sda.raw.xz)
2. Unxzip it

Then, either:
3. Extract kernel with "virt-builder --get-kernel Fedora-Minimal-armhfp-rawhide-20160106-sda.raw"
4. Run image using QEMU with

"qemu-system-arm -machine virt -m 1024 -device VGA -kernel vmlinuz-4.4.0-0.rc8.git0.1.fc24.armv7hl -initrd initramfs-4.4.0-0.rc8.git0.1.fc24.armv7hl.img -append 'rw root=LABEL=_/ rootwait' -device virtio-blk-device,drive=hd1 -drive file=Fedora-Minimal-armhfp-rawhide-20160106-sda.raw,cache=unsafe,id=hd1,if=none,format=raw -device usb-ehci -device usb-tablet -device usb-kbd -serial stdio"

or:
3. Mount image locally

Actual results:
Although symlink "initial-setup-text.service" exists in "/etc/systemd/system/multi-user.target.wants/", it leads nowhere and there is no "initial-setup" binary in "/usr/bin". When booting using QEMU, initial-setup doesn't start.

Expected results:
initial-setup should start after first boot before login screen is shown.
Comment 1 Fedora Blocker Bugs Application 2016-01-07 06:17:58 EST
Proposed as a Blocker for 24-beta by Fedora user jsedlak using the blocker tracking app because:

 Violates Alpha criterion: Release-blocking ARM disk images must boot to the initial-setup utility.
Comment 2 Dennis Gilmore 2016-01-08 15:07:11 EST
initial-setup-text is enabled in the kickstarts on the minimal and server disk images. for some reason it is not running correctly.
Comment 3 Martin Kolman 2016-01-11 09:43:10 EST
(In reply to Dennis Gilmore from comment #2)
> initial-setup-text is enabled in the kickstarts on the minimal and server
> disk images. for some reason it is not running correctly.

The Initial Setup services (initial-setup-text.service and initial-setup-graphical.service) have been merged to a single service, called just initial-setup.service.

The single service handles both GUI and TUI, based on which packages are installed. If you install both the base initial-setup package and initial-setup-gui the GUI would run. Inf only the base initial-setup package is installed, then the TUI would run. Also if the GUI fails to start Initial setup should safely fall back to TUI.

So basically only installing the initial-setup package and making sure the initial-setup.service is enabled should be enough to fix this issue.
Comment 4 Paul Whalen 2016-01-13 09:07:55 EST
symlink just needs to be updated in spins kickstarts.
Comment 5 Paul Whalen 2016-01-13 09:15:50 EST
oops, as Martin said, just enabling the service in the ks should be fine now, no more hacks needed.
Comment 6 Dennis Gilmore 2016-01-13 19:30:22 EST
should be fixed in tomorrows rawhide compose
Comment 7 Paul Whalen 2016-01-14 11:47:09 EST
Confirmed i-s runs on todays Xfce and Minimal images. Thanks!

Note You need to log in before you can comment on or make changes to this bug.