Bug 1296505 - kernel BUG at mm/memory.c:3146!
kernel BUG at mm/memory.c:3146!
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 06:59 EST by seyed alireza sanaee
Modified: 2016-10-03 10:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 10:49:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Further description (427 bytes, text/plain)
2016-04-18 04:54 EDT, henriette27
no flags Details

  None (edit)
Description seyed alireza sanaee 2016-01-07 06:59:32 EST
Description of problem:
I want to install Mosix on fedora and when I install it and want to migrate a process between nodes, the destination node crashes with "kernel BUG at mm/memory.c:3146!" error I want to note that I turn selinux off too.


Version-Release number of selected component (if applicable):
Mosix 4.3.3

How reproducible:

Just install Mosix and migrate a process between two node in one cluster.

Steps to Reproduce:
1.
2.
3.

Actual results:


[  729.380220] ------------[ cut here ]------------
[  729.380224] kernel BUG at mm/memory.c:3146!
[  729.380226] invalid opcode: 0000 [#1] SMP 
[  729.380229] Modules linked in: bnep bluetooth rfkill xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack tun bridge stp llc fuse ebtable_filter ebtables ip6table_filter ip6_tables vmw_vsock_vmci_transport vsock snd_seq_midi snd_seq_midi_event iosf_mbi coretemp snd_ens1371 gameport snd_rawmidi snd_ac97_codec crct10dif_pclmul crc32_pclmul ac97_bus crc32c_intel snd_seq snd_seq_device snd_pcm ppdev ghash_clmulni_intel snd_timer snd vmw_balloon soundcore joydev parport_pc parport vmw_vmci i2c_piix4 shpchp acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd grace sunrpc vmwgfx serio_raw drm_kms_helper ttm drm e1000 mptspi scsi_transport_spi mptscsih mptbase ata_generic pata_acpi
[  729.380256] CPU: 0 PID: 3553 Comm: mosremoted Not tainted 4.2.3-300.fc23.x86_64 #1
[  729.380266] Hardware name: VMware, Inc. VMware Virtual Platform/440BX Desktop Reference Platform, BIOS 6.00 05/20/2014
[  729.380267] task: ffff880049e21d80 ti: ffff88005b8a4000 task.ti: ffff88005b8a4000
[  729.380268] RIP: 0010:[<ffffffff811d6355>]  [<ffffffff811d6355>] handle_mm_fault+0x1095/0x17d0
[  729.380274] RSP: 0018:ffff88005b8a7b38  EFLAGS: 00010246
[  729.380274] RAX: 0000000000000100 RBX: 0000000000000000 RCX: 0000000000000120
[  729.380275] RDX: ffff88002fa8b3b8 RSI: 00003ffffffff000 RDI: 000000002fa8b067
[  729.380276] RBP: ffff88005b8a7c18 R08: 000000002e91e120 R09: ffff88003be71ab0
[  729.380277] R10: ffff8800000003b8 R11: 0000000000000120 R12: 0000000000000000
[  729.380277] R13: 00002aaaaac77000 R14: ffff88003ae1b088 R15: ffff880047bddc00
[  729.380279] FS:  00007f9e046b3700(0000) GS:ffff88007b600000(0000) knlGS:0000000000000000
[  729.380279] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  729.380280] CR2: 00007f9e046c9000 CR3: 000000003b973000 CR4: 00000000001406f0
[  729.380314] Stack:
[  729.380315]  ffff88003aff9d00 ffff880028ee2800 ffff8800362e9f00 0000000000000000
[  729.380317]  ffff88005b8a7bb8 ffffffff811cf3b7 0000014000000004 ffff88003be71ab0
[  729.380318]  ffff880047bddc00 ffff88003be71ab0 0000000000000017 00002aaa00000001
[  729.380319] Call Trace:
[  729.380323]  [<ffffffff811cf3b7>] ? follow_page_pte+0xb7/0x3f0
[  729.380324]  [<ffffffff811cf892>] ? follow_page_mask+0x1a2/0x310
[  729.380326]  [<ffffffff811cfbec>] __get_user_pages+0x1ec/0x6a0
[  729.380328]  [<ffffffff811d04a2>] get_user_pages+0x52/0x60
[  729.380329]  [<ffffffff811d09f6>] __access_remote_vm+0xe6/0x2d0
[  729.380332]  [<ffffffff811f4f71>] ? alloc_pages_current+0x91/0x100
[  729.380333]  [<ffffffff811d6c5f>] access_remote_vm+0x1f/0x30
[  729.380336]  [<ffffffff81288ae1>] mem_rw.isra.14+0xb1/0x180
[  729.380338]  [<ffffffff81288bcb>] mem_write+0x1b/0x20
[  729.380340]  [<ffffffff8121d8d7>] __vfs_write+0x37/0x100
[  729.380342]  [<ffffffff812206e8>] ? __sb_start_write+0x58/0x110
[  729.380344]  [<ffffffff8121e256>] vfs_write+0xa6/0x1a0
[  729.380346]  [<ffffffff817742f1>] ? __schedule+0x371/0x950
[  729.380348]  [<ffffffff8121f0f5>] SyS_pwrite64+0x95/0xb0
[  729.380350]  [<ffffffff81774907>] ? schedule+0x37/0x80
[  729.380352]  [<ffffffff817789ae>] entry_SYSCALL_64_fastpath+0x12/0x71
[  729.380353] Code: ff 8b 85 78 ff ff ff 89 c3 e9 40 f1 ff ff 48 8b 85 68 ff ff ff c6 40 30 00 e9 30 f1 ff ff 4c 89 c7 e8 d0 c3 fd ff e9 d6 fa ff ff <0f> 0b 83 e8 1e 83 f8 01 0f 86 26 05 00 00 c7 85 60 ff ff ff 10 
[  729.380367] RIP  [<ffffffff811d6355>] handle_mm_fault+0x1095/0x17d0
[  729.380369]  RSP <ffff88005b8a7b38>
[  729.380371] ---[ end trace 9029b62e03728ef9 ]---


Expected results:

Nothing has to be logged and migration should happen easily.
Additional info:
Comment 1 henriette27 2016-04-18 04:54 EDT
Created attachment 1148136 [details]
Further description
Comment 2 Laura Abbott 2016-09-23 15:31:11 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 3 seyed alireza sanaee 2016-10-03 07:47:24 EDT
It's alright now, I checked it out, thanks.
Comment 4 Laura Abbott 2016-10-03 10:49:06 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.