Bug 1296507 - perl-Crypt-GPG-1.64-4.fc24 FTBFS: tests fail
perl-Crypt-GPG-1.64-4.fc24 FTBFS: tests fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Crypt-GPG (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 07:01 EST by Petr Pisar
Modified: 2016-01-09 00:54 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Crypt-GPG-1.64-5.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-09 00:54:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-07 07:01:19 EST
perl-Crypt-GPG-1.64-4.fc24 fails to build in F24 because tests fail:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
NOTE: If the tests are skipped, you may need to install gpg,
      and/or set the environment variable GPGBIN to the 
      location of the gpg binary.
      If the keygen test takes a long time you may need to 
      generate more randomness on your computer (by running a 
      recursive directory listing in the background, for 
      example).
t/01-keygen.t .. ok
Use of uninitialized value in string eq at t/02-import.t line 40.
# Failed test 1 in t/02-import.t at line 44
t/02-import.t .. 
Failed 1/1 subtests 
t/03-export.t .. ok
t/04-encdec.t .. ok
t/05-sigver.t .. ok
Use of uninitialized value in string eq at t/06-keyops.t line 38.
Can't return outside a subroutine at t/06-keyops.t line 38.
t/06-keyops.t .. 
Dubious, test returned 10 (wstat 2560, 0xa00)
Failed 30/30 subtests 
Test Summary Report
-------------------
t/02-import.t (Wstat: 0 Tests: 1 Failed: 1)
  Failed test:  1
t/06-keyops.t (Wstat: 2560 Tests: 0 Failed: 0)
  Non-zero exit status: 10
  Parse errors: Bad plan.  You planned 30 tests but ran 0.
Files=6, Tests=55, 8816 wallclock secs ( 0.05 usr  0.01 sys +  0.82 cusr  0.12 csys =  1.00 CPU)
Result: FAIL

Difference between working and failing build root is:

        gnupg 	1.4.19-3.fc23 	> 	1.4.20-1.fc24
	libarchive 	3.1.2-13.fc23 	> 	3.1.2-14.fc24
	sqlite 	3.9.0-2.fc24 	> 	3.9.2-1.fc24
Comment 1 Petr Pisar 2016-01-08 04:59:25 EST
This is caused by upgrading gnupg from 1.4.19-3.fc23 to 1.4.20-1.fc24.
Comment 2 Petr Pisar 2016-01-08 06:55:36 EST
gnupg 1.4.20 refuses MD5. One has to add --allow-weak-digest-algos gnupg option to enable it, or regenerate the test keys with stronger hash algorithm.
Comment 3 Robert Scheck 2016-01-08 16:58:06 EST
Thank you for the analysis. I tried --allow-weak-digest-algos, but that
breaks with older branches, because older gnupg versions don't support the
option.
Comment 4 Robert Scheck 2016-01-09 00:54:19 EST
I now replaced the test keys with the package signing keys of EPEL 7, which
works with GnuPG 1.4.19 and 1.4.20. Thanks for the report and the analysis!

Note You need to log in before you can comment on or make changes to this bug.