This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129651 - LTC129651-warnings when installing kernel 2.6.7-1.515
LTC129651-warnings when installing kernel 2.6.7-1.515
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 129692 (view as bug list)
Depends On:
Blocks: FC3Target FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2004-08-11 10:17 EDT by Armijn Hemel
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 23:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Armijn Hemel 2004-08-11 10:17:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
I installed 2.6.7-1.515 (both SMP and non-SMP) on my machine. During
installation it complains about not being able to find some symbols
for the Tux webserver. I don't know if this is because I don't have
the Tux packages installed, but that shouldn't matter, right?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install FC2
2.install kernel 2.6.7-1.515
3.
    

Actual Results:  There were warnings.

Expected Results:  I don't want warnings!

Additional info:

[root@localhost tmp]# rpm -ivh kernel-2.6.7-1.515.i686.rpm
kernel-smp-2.6.7-1.51 5.i686.rpm
Preparing...               
########################################### [100%]
   1:kernel-smp            
########################################### [ 50%]
WARNING: /lib/modules/2.6.7-1.515smp/kernel/net/tux/tux.ko needs
unknown symbol chroot
WARNING: /lib/modules/2.6.7-1.515smp/kernel/net/tux/tux.ko needs
unknown symbol write
WARNING: /lib/modules/2.6.7-1.515smp/kernel/net/tux/tux.ko needs
unknown symbol chdir
WARNING: /lib/modules/2.6.7-1.515smp/kernel/net/tux/tux.ko needs
unknown symbol read
/
   2:kernel                
########################################### [100%]
WARNING: /lib/modules/2.6.7-1.515/kernel/net/tux/tux.ko needs unknown
symbol chroot
WARNING: /lib/modules/2.6.7-1.515/kernel/net/tux/tux.ko needs unknown
symbol write
WARNING: /lib/modules/2.6.7-1.515/kernel/net/tux/tux.ko needs unknown
symbol chdir
WARNING: /lib/modules/2.6.7-1.515/kernel/net/tux/tux.ko needs unknown
symbol read
/
Comment 1 Bill Nottingham 2004-08-11 16:57:09 EDT
*** Bug 129692 has been marked as a duplicate of this bug. ***
Comment 2 Kochin Chang 2004-08-27 15:35:27 EDT
It might have something to do with the following warnings I got when
building the kernel from source. After the build was done, "make
modules_install" and "make install" returned those same warnings
described in this bug report.

----------------------------------------
net/tux/main.c: In function `tux_chroot':
net/tux/main.c:195: warning: implicit declaration of function `chroot'
net/tux/main.c:197: warning: implicit declaration of function `chdir'
net/tux/extcgi.c: In function `handle_cgi_reply':
net/tux/extcgi.c:90: warning: implicit declaration of function `read'
net/tux/extcgi.c: In function `exec_external_cgi':
net/tux/extcgi.c:278: warning: implicit declaration of function `write'

*** Warning: "read" [net/tux/tux.ko] undefined!
*** Warning: "chdir" [net/tux/tux.ko] undefined!
*** Warning: "write" [net/tux/tux.ko] undefined!
*** Warning: "chroot" [net/tux/tux.ko] undefined!
*** Warning: "sys_close" [fs/binfmt_misc.ko] undefined!
Comment 3 Jef Spaleta 2004-09-27 23:51:23 EDT
Confirming installation of kernel-2.6.8-1.541 and kernel-smp-2.6.8-1.541
i686 no longer reports warnings about unknown symbols. But then again
541 doesn't provide tux.ko any longer... i guess that's one way to
avoid throwing warning messages.  Closing as resolution rawhide. 

-jef

Note You need to log in before you can comment on or make changes to this bug.