Bug 1296525 - perl-Net-SNPP-1.17-25.fc24 FTBFS: t/server.t test fails: Can't locate object method "timeout" via package "Net::SNPP::Server" at /usr/share/perl5/vendor_perl/Net/Cmd.pm line 201
perl-Net-SNPP-1.17-25.fc24 FTBFS: t/server.t test fails: Can't locate object ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Net-SNPP (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 07:37 EST by Petr Pisar
Modified: 2016-01-18 09:11 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-Net-SNPP-1.17-26.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 09:11:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 110978 None None None 2016-01-07 08:12 EST
CPAN 111013 None None None 2016-01-08 02:20 EST

  None (edit)
Description Petr Pisar 2016-01-07 07:37:03 EST
perl-Net-SNPP-1.17-25.fc24 fails to build in F24 because tests fail:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
# test server up and running on 20444
# attempting to connect to server using Net::SNPP
Can't locate object method "timeout" via package "Net::SNPP::Server" at /usr/share/perl5/vendor_perl/Net/Cmd.pm line 201.
#   Failed test 'connected to server using Net::SNPP client'
#   at t/server.t line 32.
Can't call method "ping" on an undefined value at t/server.t line 39.
# Looks like you planned 15 tests but ran 4.
# Looks like you failed 1 test of 4 run.
# Looks like your test exited with 9 just after 4.
t/server.t .. 
Dubious, test returned 9 (wstat 2304, 0x900)
Failed 12/15 subtests 

Difference between working and failing build root:

        perl-libnet 	3.07-1.fc24 	> 	3.08-1.fc24
	perl-Math-BigInt 	1.9997.14-1.fc24 	> 	1.9997.15-1.fc24
	file 	5.25-3.fc24 	> 	5.25-4.fc24
	file-libs 	5.25-3.fc24 	> 	5.25-4.fc24
Comment 1 Petr Pisar 2016-01-07 07:50:10 EST
This is caused by upgrading perl-libnet from 3.07-1.fc24 to 3.08-1.fc24.
Comment 2 Petr Pisar 2016-01-07 08:12:53 EST
I think it's a bug in Net::Cmd. I raised a question there.
Comment 3 Petr Pisar 2016-01-08 02:20:30 EST
Net::Cmd upstream thinks it's an insufficiency in Net::Cmd documentation and all Net::Cmd-extending classes like Net::SNPP should provided it's timeout() method implementation.

Note You need to log in before you can comment on or make changes to this bug.