Bug 129654 - The libXaw3d is missing from XFree86-libs in RHEL3-U2, preventing emacs installation
The libXaw3d is missing from XFree86-libs in RHEL3-U2, preventing emacs insta...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: Xaw3d (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-11 10:52 EDT by David Howells
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 02:49:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Howells 2004-08-11 10:52:13 EDT
Description of problem: 
 
The XFree86-libs rpm no longer contains the libXaw3d shared library. 
This prevents the emacs RPM from installing, since that library user 
by emacs. 
 
Version-Release number of selected component (if applicable): 
 
XFree86-libs-4.3.0-32.EL (RHEL3) has it. 
 
XFree86-libs-4.3.0-62.EL (RHEL3 U2) does not. 
 
Whilst bug this applies to ppc/ppc64, it also appears to apply to 
x86. 
 
How reproducible: 
 
100% 
 
Steps to Reproduce: 
1. Install XFree86-libs from RHEL3-U2 
2. Try to install emacs from RHEL3 (there is no RHEL3-U2 version). 
3. 
   
Actual results: 
 
[root@powerv2 root]# rpm -i /tmp/emacs-21.3-4.ppc.rpm  
error: Failed dependencies: 
        libXaw3d.so.7 is needed by emacs-21.3-4 
 
 
Expected results: 
 
No error; it should just install. 
 
Additional info:
Comment 1 Mike A. Harris 2004-08-11 18:44:15 EDT
libXaw3d is not part of XFree86 nor XOrg, and never was.  It is a
separate library that was provided in it's own package.

Reassigning to Xaw3d component.
Comment 2 Ngo Than 2004-08-12 02:49:13 EDT
Xaw3d is a separate package. Xaw3d-1.5-18 was included in RHEL3!

please make sure that you have to install Xaw3d package!

Note You need to log in before you can comment on or make changes to this bug.