Bug 1296558 - v2v:sort the list of VMs by name
v2v:sort the list of VMs by name
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Sharon Gratch
Nisim Simsolo
: Improvement, UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 09:29 EST by Nisim Simsolo
Modified: 2016-07-11 19:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The Import Virtual Machine(s) window now lists virtual machines in alphabetical order, even after dragging virtual machines between lists.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:01:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
gklein: testing_plan_complete-
mgoldboi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57552 master MERGED webadmin: sort the vms lists in import vms window 2016-05-18 05:25 EDT

  None (edit)
Description Nisim Simsolo 2016-01-07 09:29:49 EST
Description of problem:
When loading available VMs to import, "Virtual machines on source" are not sorted by any order.
It would be better if the sort order will be alphabetically (like in Virtual machines tab for example).
Incorrect sorting is also true for "virtual machines to import" list.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64
vdsm-4.17.15-0.el7ev
sanlock-3.2.4-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Browse webadmin and open "import" dialog.
2. Enter VMware environment details and click "load" button.
3.

Actual results:
VMs listed in "virtual machines on source"/"virtual machines to import" are not listed by any logical order.

Expected results:
Both lists should be sorted in an alphabetically order.

Additional info:
See attached screenshots.
Comment 1 Moran Goldboim 2016-03-27 05:14:04 EDT
converting this one to 4.1 RFE.
Comment 2 Michal Skrivanek 2016-04-25 06:13:03 EDT
sorting by name should be fairly simple (note that generic sortable columns would be much more complicated, so let's not over engineer this)
Comment 4 Sandro Bonazzola 2016-05-02 06:06:59 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 5 Sharon Gratch 2016-05-17 07:34:46 EDT
Please note that after the bug fix, both lists ("Virtual Machines on Source" and "Virtual Machines to Import" are now displaying the VMs sorted, in an alphabetically order by VM name (the same order as displayed in the Storage->VM Import list).

The lists remains sorted at any given moment: after loading the VMs to import and also after dragging the VMs from list to list.
Comment 6 Nisim Simsolo 2016-06-08 06:00:23 EDT
Verification build:
ovirt-engine-4.1.0-0.0.master.20160606111312.gitc7af584.el7.centos.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.14.x86_64
vdsm-4.18.999-31.gitb0bc4c6.el7.centos.x86_64
libvirt-client-1.2.17-13.el7_2.4.x86_64
sanlock-3.2.4-2.el7_2.x86_64

Verification scenario: 
1. Create VMs in VMwrae with diverse naming (names that start with numbers, with capital letters and symbols)
2. Browse webadmin -> Virtual machines tab -> import
2. Insert VMware details and click "load" button.
3. Verify VMs in "Virtual Machines on Source" pane are sorted in alphabetical order.
4. Move all VMs to "Virtual Machines to Import" pane.
5. Verify VMs are sorted in alphabetical order.
6. Move some VMs back to "Virtual Machines on Source" and verify both panes are sorted in alphabetical order.
6. Click "next" button. 
5. Verify second import dialog is also sorting VMs in alphabetical order.
6. click "back" button.
7. Verify VMs in both panes are sorted in alphabetical order.
8. insert different VMware environment details and click "load" button.
9. Verify VMs from the previous load are not listed anymore. and the last "load" VMs are listed in alphabetical order.

scenario added to v2v test plan.
Comment 7 Sandro Bonazzola 2016-07-05 04:01:01 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.