Bug 1296560 - OpenIPMI-modalias RPM owns /var/run/OpenIPMI, but /var/run is tmpfs, need to use tmpfiles
OpenIPMI-modalias RPM owns /var/run/OpenIPMI, but /var/run is tmpfs, need to ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Josef Ridky
Rachel Sibley
:
Depends On:
Blocks: 1256306 1289025 1305230
  Show dependency treegraph
 
Reported: 2016-01-07 09:36 EST by giulioo
Modified: 2017-02-09 03:56 EST (History)
2 users (show)

See Also:
Fixed In Version: OpenIPMI-2.0.19-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:04:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2016-01-07 09:36:48 EST
Description of problem:
OpenIPMI-modalias RPM owns /var/run/OpenIPMI, but /var/run in RHEL7 points to /run which is in tmpfs.

For this reason the "rpm verify" of OpenIPMI-modalias will fail.

Version-Release number of selected component (if applicable):
OpenIPMI-modalias-2.0.19-11.el7.x86_64

How reproducible:
always

Steps to Reproduce:

# rpm -qa|grep OpenIPMI
OpenIPMI-modalias-2.0.19-11.el7.x86_64

# rpm -ql OpenIPMI-modalias
/etc/modprobe.d/OpenIPMI.conf
/var/run/OpenIPMI

# rpm -V OpenIPMI-modalias
missing     /var/run/OpenIPMI
#

Actual results:
rpm verify fails

Expected results:
rpm verify succeeds

Additional info:
need to use tmpfiles for /var/run/OpenIPMI
Comment 2 Boris Ranto 2016-01-07 10:46:43 EST
We can simply stop manually installing the directory in %install phase and then we won't have to package it at all. The creation of that directory is handled by systemd just fine.
Comment 5 Rachel Sibley 2016-05-25 09:28:48 EDT
ALL TESTS PASSED

Before
==========================
# uname -r
3.10.0-327.el7.x86_64

#  rpm -qa|grep OpenIPMI
OpenIPMI-libs-2.0.19-11.el7.x86_64
OpenIPMI-2.0.19-11.el7.x86_64

#  rpm -ql OpenIPMI-modalias
/etc/modprobe.d/OpenIPMI.conf
/var/run/OpenIPMI

#  rpm -V OpenIPMI-modalias
missing     /var/run/OpenIPMI

After
==========================
# uname -r
3.10.0-408.el7.x86_64

# rpm -qa|grep OpenIPMI
OpenIPMI-libs-2.0.19-14.el7.x86_64
OpenIPMI-2.0.19-14.el7.x86_64
OpenIPMI-modalias-2.0.19-14.el7.x86_64

#  rpm -ql OpenIPMI-modalias
/usr/lib/modprobe.d/OpenIPMI.conf

#  rpm -V OpenIPMI-modalias
#
Comment 7 Rachel Sibley 2016-10-20 08:12:08 EDT
Moving back to Verified State as it was incorrectly moved back to Assigned when switching the package owner.
Comment 9 errata-xmlrpc 2016-11-03 21:04:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2225.html

Note You need to log in before you can comment on or make changes to this bug.