Bug 1296562 - openstack undercloud install fails: unable to start openstack-ironic-inspector-dnsmasq
openstack undercloud install fails: unable to start openstack-ironic-inspecto...
Status: CLOSED DUPLICATE of bug 1280083
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 09:52 EST by lance
Modified: 2016-04-18 03:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 10:35:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 lance 2016-01-07 10:31:51 EST
journalctl -xe shows this error:

Jan 07 15:29:17 calico-rh-director.datcon.co.uk neutron-openvswitch-agent[14804]: 2016-01-07 15:29:17.976 14804 DEBUG neutron.plugins.ml2.drivers.openvswitch.agent.ovs_neutron_agent [req-aea4b039-9ac5-4768-b357-6c343f7c018d - - - - -] Ag
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.197 11915 DEBUG ironic_inspector.main [-] Running periodic update of filters periodic_update /usr/lib/python2.7/site-packages/ironic_inspector/m
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.197 11915 DEBUG keystoneclient.auth.identity.v2 [-] Making authentication request to http://192.0.2.1:5000/v2.0/tokens get_auth_ref /usr/lib/pyt
Jan 07 15:29:18 calico-rh-director.datcon.co.uk keystone-all[13727]: 2016-01-07 15:29:18.200 13746 DEBUG keystone.middleware.core [req-3dc9a8b0-7291-4e1f-8aa7-339b448032c8 - - - - -] There is either no auth token in the request or the ce
Jan 07 15:29:18 calico-rh-director.datcon.co.uk keystone-all[13727]: 2016-01-07 15:29:18.201 13746 INFO keystone.common.wsgi [req-3dc9a8b0-7291-4e1f-8aa7-339b448032c8 - - - - -] POST http://192.0.2.1:5000/v2.0/tokens
Jan 07 15:29:18 calico-rh-director.datcon.co.uk keystone-all[13727]: 2016-01-07 15:29:18.205 13746 WARNING keystone.common.wsgi [req-3dc9a8b0-7291-4e1f-8aa7-339b448032c8 - - - - -] Authorization failed. Could not find user: ironic (Disab
Jan 07 15:29:18 calico-rh-director.datcon.co.uk keystone-all[13727]: 2016-01-07 15:29:18.208 13746 INFO eventlet.wsgi.server [req-3dc9a8b0-7291-4e1f-8aa7-339b448032c8 - - - - -] 192.0.2.1 - - [07/Jan/2016 15:29:18] "POST /v2.0/tokens HTT
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 DEBUG keystoneclient.session [-] Request returned failure status: 401 request /usr/lib/python2.7/site-packages/keystoneclient/session.
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 DEBUG keystoneclient.v2_0.client [-] Authorization Failed. get_raw_token_from_identity_service /usr/lib/python2.7/site-packages/keysto
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main [-] Periodic update failed
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main Traceback (most recent call last):
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/ironic_inspector/main.py", line 272, in periodic_update
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     firewall.update_filters()
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/ironic_inspector/firewall.py", line 123, in update_filters
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     ironic = utils.get_client() if ironic is None else ironic
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/ironic_inspector/utils.py", line 93, in get_client
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     return client.get_client(1, **args)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/ironicclient/client.py", line 86, in get_client
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     _ksclient = _get_ksclient(**ks_kwargs)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/ironicclient/client.py", line 35, in _get_ksclient
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     insecure=kwargs.get('insecure'))
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 166, in __init__
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     self.authenticate()
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/utils.py", line 337, in inner
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     return func(*args, **kwargs)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/httpclient.py", line 589, in authenticate
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     resp = self.get_raw_token_from_identity_service(**kwargs)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 200, in get_raw_token_from_i
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     return plugin.get_auth_ref(self.session)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/auth/identity/v2.py", line 88, in get_auth_ref
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     authenticated=False, log=False)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/session.py", line 501, in post
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     return self.request(url, 'POST', **kwargs)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/utils.py", line 337, in inner
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     return func(*args, **kwargs)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main   File "/usr/lib/python2.7/site-packages/keystoneclient/session.py", line 401, in request
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main     raise exceptions.from_response(resp, method, url)
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main Unauthorized: Could not find user: ironic (Disable debug mode to suppress these details.) (HTTP 401) (Requ
Jan 07 15:29:18 calico-rh-director.datcon.co.uk ironic-inspector[11915]: 2016-01-07 15:29:18.209 11915 ERROR ironic_inspector.main
Comment 3 Mike Burns 2016-01-07 10:35:43 EST
Please do not include the ftp url in bug reports.  

Closing as a duplicate of bug 1280083

*** This bug has been marked as a duplicate of bug 1280083 ***

Note You need to log in before you can comment on or make changes to this bug.