Bug 1296565 - rhel-osp-director: 7.2-> 8.0 upgrade: after 'yum update' and successful re-run of 'openstack undercloud install' the overcloud nodes show the same IP (from ctlplane network) on all NICs.
rhel-osp-director: 7.2-> 8.0 upgrade: after 'yum update' and successful re-ru...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Brad P. Crochet
Alexander Chuzhoy
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 09:56 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:45:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2016-01-07 09:56:53 EST
rhel-osp-director: 7.2-> 8.0 upgrade: after 'yum update' and successful re-run of 'openstack undercloud install' the overcloud nodes show the same IP (from ctlplane network) on all NICs.


Environment:
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
instack-undercloud-2.2.1-2.el7ost.noarch
openstack-tripleo-common-0.0.2-5.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch


Steps to reproduce:
1. Deploy 7.2 undercloud and HA overcloud with vxlan network backend + network isolation. Check that the overcloud nodes have proper IP addresses.
2. Upgrade the undercloud to 8.0: 
   a. Update the repos and RPMs.
   b. Run "openstack undercloud install"

3. Login to any overcloud node and run "ip a"

Result:
You'll see the same IP reported on all NICs.
Also, if you source the stackrc on the undercloud node and run "neutron net-list" - you'll see only the ctlplane network. Other networks were removed.

The issue reproduced on 2 VM based setups.
Comment 4 Hugh Brock 2016-02-07 09:07:19 EST
Brad, I thought this was fixed with passing the right control-plane-static-IP environment in -- am I wrong about that?
Comment 5 Brad P. Crochet 2016-02-09 11:48:12 EST
This no longer appears to be an issue. No need to pass anything else. Please retest.
Comment 7 Alexander Chuzhoy 2016-02-24 17:51:02 EST
Verified:
Environment:
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-common-0.1.1-1.el7ost.noarch
instack-undercloud-2.2.2-2.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch


The reported issue doesn't reproduce.
Comment 9 errata-xmlrpc 2016-04-07 17:45:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.