Bug 1296576 - Cannot create an Alert that sends a Management Event not defined in MiqEventDefinition
Cannot create an Alert that sends a Management Event not defined in MiqEventD...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.3
Assigned To: Lucy Fu
Dmitry Misharov
: ZStream
Depends On: 1296248
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 10:28 EST by John Prause
Modified: 2016-04-13 14:40 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1296248
Environment:
Last Closed: 2016-04-13 14:40:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-02-10 14:54:48 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5c54e4886269cde56b2982ac1782ea5e37b358d7

commit 5c54e4886269cde56b2982ac1782ea5e37b358d7
Merge: 8dae530 4658374
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Feb 10 14:30:22 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Feb 10 14:30:22 2016 -0500

    Merge branch '5.5.z-user_event_alert_1296248' into '5.5.z'
    
    Fix Alert for Management Event.
    
    Clean cherry-pick from [original](https://github.com/ManageIQ/manageiq/pull/6156).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296576
    
    See merge request !762

 app/models/custom_event.rb                         |   2 +
 app/models/miq_alert.rb                            |  19 +-
 app/models/miq_event.rb                            |   2 +
 .../Event/CustomEvent/Alert.class/__class__.yaml   | 433 +++++++++++++++++++++
 .../System/Event/CustomEvent/__namespace__.yaml    |  11 +
 .../service_models/miq_ae_service_custom_event.rb  |   4 +
 spec/models/miq_alert_spec.rb                      |  48 +++
 7 files changed, 516 insertions(+), 3 deletions(-)
Comment 4 Dmitry Misharov 2016-03-30 11:54:37 EDT
Verified in 5.5.3.2.20160318152106_92d2d67. The Management Event was successfully invoked.
Comment 6 errata-xmlrpc 2016-04-13 14:40:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.