Bug 1296578 - [7.3 FEAT] Update criu technology preview to latest upstream version on 7.3
Summary: [7.3 FEAT] Update criu technology preview to latest upstream version on 7.3
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: criu   
(Show other bugs)
Version: 7.3
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Adrian Reber
QA Contact: Chao Ye
Lenka Špačková
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 1295826
TreeView+ depends on / blocked
 
Reported: 2016-01-07 15:29 UTC by Adrian Reber
Modified: 2016-11-04 01:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Technology Preview
Doc Text:
_criu_ rebased to version 2.3 Red Hat Enterprise Linux 7.2 introduced the *criu* tool as a Technology Preview. This tool implements *Checkpoint/Restore in User-space (CRIU)*, which can be used to freeze a running application and store it as a collection of files. Later, the application can be restored from its frozen state. Note that the *criu* tool depends on *Protocol Buffers*, a language-neutral, platform-neutral extensible mechanism for serializing structured data. The _protobuf_ and _protobuf-c_ packages, which provide this dependency, were also introduced in Red Hat Enterprise Linux 7.2 as a Technology Preview. With Red Hat Enterprise Linux 7.3, the _criu_ packages have been upgraded to upstream version 2.3, which provides a number of bug fixes and enhancements over the previous version. Notably, *criu* is now available also on Red Hat Enterprise Linux for POWER, little endian. Additionally, *criu* can now be used for following applications running in a Red Hat Enterprise Linux 7 *runc* container: * vsftpd * apache httpd * sendmail * postgresql * mongodb * mariadb * mysql * tomcat * dnsmasq
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:57:06 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2268 normal SHIPPED_LIVE criu bug fix and enhancement update 2016-11-03 13:34:09 UTC

Description Adrian Reber 2016-01-07 15:29:28 UTC
As long as criu is a technology preview we should try to follow upstream. Upstream is still fast moving and is still implementing important features.

There are already a few backports in the existing criu package for RHEL 7.2 and especially for the PPC64LE support a newer criu version is required.

Comment 9 Adrian Reber 2016-09-13 09:58:54 UTC
Hello Lenka,

the documentation text sounds correct. Thanks!

Comment 17 errata-xmlrpc 2016-11-04 01:57:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2268.html


Note You need to log in before you can comment on or make changes to this bug.