Bug 1296581 - Running a Control Action of "Invoke a Custom Automation" results in the error "MiqAeServiceModelBase.ar_method raised: <RuntimeError>: <user_id not specified in Automation request>"
Running a Control Action of "Invoke a Custom Automation" results in the error...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.2
Assigned To: Lucy Fu
Nandini Chandra
: ZStream
Depends On: 1296122
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 10:35 EST by John Prause
Modified: 2016-02-10 10:31 EST (History)
12 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, running a control policy containing an action type that invoked a custom automation always failed with an error that the user_id was not specified in the automation request. This error was caused by missing user id, miq_group_id and tenant_id arguments in the automation request. This bug was fixed by passing the missing user_id, miq_group_id and tenant_id arguments in the automation request. Invoking a custom automation now works as expected in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1296122
Environment:
Last Closed: 2016-02-10 10:31:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-01-11 20:27:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=bfd53ca44b22e2433e1b29d071fede2cafd879c5

commit bfd53ca44b22e2433e1b29d071fede2cafd879c5
Merge: 7b5fed5 f944a4c
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Mon Jan 11 20:26:18 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Mon Jan 11 20:26:18 2016 -0500

    Merge branch '5.5.z-user_id_for_custom_ae_action_1296122' into '5.5.z'
    
    user_id, miq_group_id and tenant_id are required in Automation request.
    
    A clean cherry-pick of [original](https://github.com/ManageIQ/manageiq/pull/6072).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296581
    
    See merge request !699

 app/models/miq_action.rb       | 21 +++++++++++++++++++++
 spec/models/miq_action_spec.rb |  8 +++++++-
 2 files changed, 28 insertions(+), 1 deletion(-)
Comment 4 Nandini Chandra 2016-01-22 12:23:59 EST
Verified in 5.5.2.1
Comment 5 Nandini Chandra 2016-01-22 12:35:18 EST
Verified that custom automation is successfully run when it's defined as a Control Policy action.
Comment 6 errata-xmlrpc 2016-02-10 10:31:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.