Bug 1296583 - Redshift - RS does not support ASCII function
Summary: Redshift - RS does not support ASCII function
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER1
: 6.3.0
Assignee: Van Halbert
QA Contact: Juraj Duráni
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-07 15:38 UTC by Juraj Duráni
Modified: 2016-08-24 11:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
driver - PostgreSQL 9.2 translator - postgresql
Last Closed: 2016-08-24 11:46:14 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker TEIID-3887 0 Major Resolved Redshift - RS does not support ASCII function 2016-05-09 09:44:14 UTC

Description Juraj Duráni 2016-01-07 15:38:13 UTC
Description of problem:
Redshift database does not support ASCII function

E.g. *SELECT INTKEY, ASCII(INTKEY) FROM BQT1.SmallA ORDER BY INTKEY* is translated as *SELECT g_0.intkey AS c_0, ascii(cast(g_0.intkey AS varchar(4000))) AS c_1 FROM smalla AS g_0 ORDER BY c_0*

Result:
Caused by: org.postgresql.util.PSQLException: ERROR: Specified types or functions (one per INFO message) not supported on Redshift tables.


Steps to Reproduce:
<vdb name="test" version="1">
    <model name="Source" type="PHYSICAL">
        <source name="rs" connection-jndi-name="java:/Redshift" translator-name="postgresql"/>
        <metadata type="DDL">
            <![CDATA[create foreign table SmallA (
                intkey integer OPTIONS(NAMEINSOURCE 'intkey', NATIVE_TYPE 'int4'),
                timevalue timestamp OPTIONS(NAMEINSOURCE 'timevalue', NATIVE_TYPE 'timestamp')) OPTIONS(NAMEINSOURCE 'smalla');
            ]]>
        </metadata>
    </model>
</vdb>
Actual results:


Expected results:


Additional info:

Comment 1 JBoss JIRA Server 2016-01-08 13:48:18 UTC
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3887 to Resolved

Comment 2 Van Halbert 2016-01-08 13:53:42 UTC
Note:  a new redshift translator has been created to account for the different capabilities than the postgresql translator.


Note You need to log in before you can comment on or make changes to this bug.