Bug 1296593 - [RFE] v2v: notify in import dialog that attaching VirtIO drivers to Windows VM is essential.
[RFE] v2v: notify in import dialog that attaching VirtIO drivers to Windows V...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.3
: 3.6.3.1
Assigned To: Tomas Jelinek
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 10:51 EST by Nisim Simsolo
Modified: 2016-02-18 06:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:16:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.z?
rule-engine: planning_ack?
tjelinek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
second import dialog (62.58 KB, image/png)
2016-01-07 10:54 EST, Nisim Simsolo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52871 master MERGED webadmin: added warning when import windows without virtio 2016-02-01 05:02 EST
oVirt gerrit 52928 ovirt-engine-3.6 MERGED webadmin: added warning when import windows without virtio 2016-02-01 10:28 EST
oVirt gerrit 53028 ovirt-engine-3.6.3 MERGED webadmin: added warning when import windows without virtio 2016-02-03 06:18 EST

  None (edit)
Description Nisim Simsolo 2016-01-07 10:51:27 EST
Description of problem:
- When importing Windows VM from VMware, the imported VM disk interface is VirtIO.
- Running imported VM without VirtIO drivers installed, leads to BSOD and it is impossible to install VirtIO drivers on this VM.
- The only way to make it run properly, is by attaching VirtIO drivers to VM during import process.
- Currently, it is unclear that VirtIO-drivers are essential for Windows based VMs. It would be nice to have a notification for it in second import dialog when selecting Windows OS in "operating system" dropbox.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6


Additional info:
Screenshot of current dialog attached.
Comment 1 Nisim Simsolo 2016-01-07 10:54 EST
Created attachment 1112485 [details]
second import dialog
Comment 2 Shahar Havivi 2016-01-18 04:48:09 EST
We cannot determine that the os is Windows only virt-v2v knows when it start the process.
Its not a must to set the virtio drivers via oVirt since it can be installed by the user on the host locally.
Comment 3 Tomas Jelinek 2016-02-01 05:09:20 EST
moving back to post, it needs to be backported
Comment 4 Tomas Jelinek 2016-02-02 05:51:53 EST
moving back to post - to make it modified for 3.6.4 it has to be backported once more
Comment 5 Yaniv Kaul 2016-02-04 08:45:03 EST
Tomas - 3.6.4 is our GA build - this should either go to 3.6.3 or be deferred to z-stream.
Comment 6 Tomas Jelinek 2016-02-04 10:24:04 EST
Left the 3.6.4 there just in case it will not make it to 3.6.3... But it is merged, so changing target to 3.6.3
Comment 7 Nisim Simsolo 2016-02-11 09:56:17 EST
Verified using build:
rhevm-3.6.3.1-0.1.el6

Now, when selecting windows OS during import dialog, the next notification appear with red fonts:
"You have selected windows OS and have not selected VirtIO drivers. This may cause the system not to boot up."

Note You need to log in before you can comment on or make changes to this bug.