Bug 1296612 - [SME] Interactive installer should ask for default subdomain
[SME] Interactive installer should ask for default subdomain
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 11:29 EST by Josh Preston
Modified: 2016-02-29 07:57 EST (History)
5 users (show)

See Also:
Fixed In Version: atomic-openshift-utils-3.0.39-1.git.0.226c87d.el7aos.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 07:57:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Preston 2016-01-07 11:29:00 EST
Description of problem:

The quick start should ask the default subdomain for a smoother experience to correlate to the ‘osm_default_subdomain’ ansible configuration options.  This could then populate the /root/.config/openshift/.ansible/hosts file appropriately.

Version-Release number of selected component (if applicable):

atomic-openshift-utils-3.0.20-1.git.0.3703f1b.el7aos.noarch

How reproducible:

always

Steps to Reproduce:
1. setup the wildcard dns entry
2. run the atomic-openshift-installer
3. 

Actual results:

Installs correctly

Expected results:

Would like to be asked my default subdomain during the interactive install and for it to be configured properly.

Additional info:
Comment 3 Gaoyun Pei 2016-02-14 01:28:06 EST
Verify this bug with atomic-openshift-utils-3.0.40-1.git.22.da21865.el7aos.noarch

The installer would ask user to input subdomain during the interactive, configure it as "abc-test.com", then continue installation.

Check the ansible inventory:
[OSEv3:vars]
osm_default_subdomain=abc-test.com

After installation, check master-config.yaml:
routingConfig:
  subdomain:  "abc-test.com"
Comment 5 errata-xmlrpc 2016-02-29 07:57:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0311

Note You need to log in before you can comment on or make changes to this bug.