Bug 1296617 - sos plugin: please collect list of files at /usr/libexec/vdsm/hooks
sos plugin: please collect list of files at /usr/libexec/vdsm/hooks
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.6
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Kenigsberg
Aharon Canan
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 11:40 EST by Julio Entrena Perez
Modified: 2016-01-18 07:55 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 04:25:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julio Entrena Perez 2016-01-07 11:40:19 EST
Description of problem:
The vdsm plugin should collect a recursive list of the files at /usr/libexec/vdsm/hooks .
Directories at that location contain hooks or custom scripts that users can add for vdsm to execute when certain actions happen.
Badly written custom hooks can cause all sorts of problems including vdsmd failing to start.
A simple "ls -lR" of /usr/libexec/vdsm/hooks would reveal the presence of any vdsm hook.

Version-Release number of selected component (if applicable):
sos-3.2-35.el7

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Pavel Moravec 2016-01-08 02:45:19 EST
Hello,
just output of "ls -lR /usr/libexec/vdsm/hooks" command is requested to be collected? Since then you won't see the script content to evaluate possible issue the script can cause.

Further, where the command add? To ovirt plugin? Since vdsm plugin is not maintained by sos, neither in upstream or downstream.
Comment 3 Julio Entrena Perez 2016-01-08 04:49:08 EST
Usually there are no custom hooks, so output of "ls -lR /usr/libexec/vdsm/hooks" would be enough.
If there are one or more hooks we can always request customer to share those after we detect its presence.

This should be collected by the vdsm plugin, since the hooks will be in the hosts. Should this be re-assigned to another component then?
Comment 4 Pavel Moravec 2016-01-08 07:16:07 EST
(In reply to Julio Entrena Perez from comment #3)
> This should be collected by the vdsm plugin, since the hooks will be in the
> hosts. Should this be re-assigned to another component then?

Lee, do you know? (I noticed you mentioned the plugin in https://github.com/sosreport/sos/pull/235)
Comment 5 Julio Entrena Perez 2016-01-08 07:23:27 EST
Lee is no longer involved in RHEV.

# yum -q provides /usr/lib/python2.6/site-packages/sos/plugins/vdsm.py | tail -9

vdsm-4.16.30-1.el6ev.x86_64 : Virtual Desktop Server Manager
Repo        : installed
Matched from:
Other       : Provides-match:
            : /usr/lib/python2.6/site-packages/sos/plugins/vdsm.py

I'm changing the component to vdsm then, thank you Pavel.
Comment 6 Dan Kenigsberg 2016-01-10 10:22:20 EST
I don't mind collecting the list of hook files, but please note that the required information hould be available within the output of getVdsCapaibilities (which is already collected by sos, as long as Vdsm is running).

Isn't that enough?
Comment 7 Julio Entrena Perez 2016-01-11 04:25:37 EST
Thank you Dan, that's enough indeed, sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.