Bug 1296657 - dnf-plugins-core version of repoquery with --resolve much slower than yum-utils
dnf-plugins-core version of repoquery with --resolve much slower than yum-utils
Status: CLOSED DUPLICATE of bug 1279538
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-01-07 13:44 EST by John Hein
Modified: 2016-01-11 08:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-11 08:11:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Hein 2016-01-07 13:44:36 EST
Description of problem:

old way with yum-utils: repoquery --requires --resolve <some_pkg>
new way with dnf-plugins-core: dnf repoquery --requires --resolve <some_pkg>

Version-Release number of selected component (if applicable):

fedora 22

% rpm -qa | egrep 'yum-utils|dnf-plugins-core'

How reproducible:


Steps to Reproduce:

Compare wall time to run yum-utils' repoquery vs. dnf-plugins-core:


sh -c 'time repoquery --requires --resolve gscan2pdf'
real    0m4.316s
user    0m4.064s
sys     0m0.249s

sh -c 'time dnf repoquery --requires --resolve gscan2pdf'
real    4m7.166s
user    4m3.422s
sys     0m3.731s

On both cases, the metadata cache was up to date before running the repoquery.

Without --resolve, the times are comparable (< 5 s).

Is this a difference due to fundamentally different issues between yum & dnf?  The magnitude of speed difference seems to be indicate than just 'python adds a little overhead'.

Hints to where to start profiling are appreciated - I currently have near zero internals knowledge for yum/dnf, but I'm willing to dig a little.
Comment 1 Honza Silhan 2016-01-11 08:11:46 EST

*** This bug has been marked as a duplicate of bug 1279538 ***

Note You need to log in before you can comment on or make changes to this bug.