Bug 129667 - kernel-2.6.7-1.509 panic at boot
kernel-2.6.7-1.509 panic at boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-11 13:32 EDT by Satish Balay
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 11:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/boot/brub/menu.lst (1.52 KB, text/plain)
2004-08-12 19:22 EDT, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2004-08-11 13:32:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040806

Description of problem:
Installing latest rawhide kernel would give 'panic' at reboot.

Version-Release number of selected component (if applicable):
mkinitrd-4.0.3-1 kernel-2.6.7-1.509, 515

How reproducible:
Always

Steps to Reproduce:
1. install latest rawhide updates including mkinitrd-4.0.3-1
2. install any kernel (I've installed the latest 509,515)
3. reboot
    

Actual Results:  
-----
Uncompressing Linux... Ok, booting the kernel.
audit(1092071072.280:0): initialized
Red Hat nash version 4.0.2 starting
exec of init failed!!!: 14
Kernel panic: Attempted to kill init!
----


Expected Results:  
proper boot

Additional info:

This is on a ThinkPad 600E with boot options:

kernel /vmlinuz-2.6.7-1.509 ro root=LABEL=/ selinux=0 rhgb quiet acpi=off

Same thing happend with installing 515 or 478 kernel (FC3T1)

On reverting mkinitrd to FC3T1 version (mkinitrd-3.5.24-1) and
reinstalling kernel-515 - it boots fine.

So I guess mkinitrd-4.0.3-1 has some issues.

It could be related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=129120
Comment 1 Jeremy Katz 2004-08-11 13:34:27 EDT
Does it work if you remove rhgb and quiet from your boot options?
Comment 2 Satish Balay 2004-08-11 13:44:50 EDT
It boot fine if I remove "rhgb quiet"
Comment 3 Gerry Tool 2004-08-11 15:06:32 EDT
I was having this same kernel panic problem with kernel 509.  Removing
"rhgb quiet" from the boot options also allowed me to boot.
Comment 4 Jeremy Katz 2004-08-11 15:57:48 EDT
Could you try again with mkinitrd 4.0.4 (will be at
http://people.redhat.com/~katzj/mkinitrd/ as soon as it's done building)?
Comment 5 Satish Balay 2004-08-11 18:36:41 EDT
I've tried mkinitrd 4.0.4-1 (with kernel 478) - I still get a panic
(however a different error)

----
Red Hat nash version 4.0.4 starting
mount: error 6 mounting ext3
switchroot: mount failed: 22
Kernel panic: Attempted to kill init!

----

removing 'rhgb quiet' is a bit more verbose - but stops with the same
error
Comment 6 Jeremy Katz 2004-08-11 21:49:36 EDT
Can you provide the more verbose bit? 
Comment 7 James Laska 2004-08-12 09:47:36 EDT
Still observing failure with latest mkinitrd-4.0.4-1.  I am able to
bypass the failure by simply removing "quiet" from the kernel boot args.
Comment 8 Satish Balay 2004-08-12 10:48:37 EDT
Ok - I'm typing in things I see on the screen (so ignore typos).. I've
also updated today's rawhide - which has kernel 517 (and the following
messages are with 517)

------------
serio: i8042 AUX port at 0x60,0x64 irq 12
input: PS/2 Generic Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISCS=27
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Freeing unused kernel memory: 132k freed
Red Hat nash version 4.0.4 starting
Mounted /proc filesystem
Mounting sysfs
Loading jbd.ko module
Loading ext3.ko module
Creating block devices
Creating root device
Mounting root filesystem
mount: error 6 mounting ext3
Switching to new root
switchroot: mount failed: 22
Kernel panic: Attempted to kill init!
Comment 9 Yao Zhang 2004-08-12 13:41:45 EDT
The same panic for kernel 515 and 517:

Mounting root filesystem
mount: error 6 mounting ext3
Switching to new root
switchroot: mount failed: 22
Kernel panic: Attempted to kill init!

But 509 is fine.  I have up2date rawhide with 
mkinitrd-4.0.4-1.
Comment 10 Jeremy Katz 2004-08-12 13:54:37 EDT
mkinitrd 4.0.5 from http://people.redhat.com/~katzj/mkinitrd/ should
be better.  Sorry, was asleep at the wheel or something yesterday.
Comment 11 Satish Balay 2004-08-12 14:19:38 EDT
removing "rhgb quit" works now - but with the flags enabled - I'm back
to the original problem:

exec of init failed!!!: 14
Comment 12 Jeremy Katz 2004-08-12 18:56:10 EDT
Can you do

wget http://people.redhat.com/~katzj/nash-test ; cp nash-test
/sbin/nash; /sbin/mkinitrd -v -f /boot/initrd-ver-test ver

(Substituting ver and the name of the initrd appropriately of course)
and see what it tells you?  Also, could you attach your complete
grub.conf?
Comment 13 Satish Balay 2004-08-12 19:20:29 EDT
[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.7-1.515 #1 Tue Aug 10 16:06:20 EDT
2004 i686 i686 i386 GNU/Linux
[root@localhost ~]# /sbin/mkinitrd -v -f
/boot/initrd-2.6.7-1.517-test.img  2.6.7-1.517
Creating initramfs
Looking for deps of module ide-disk
Looking for deps of module ext3  jbd
Looking for deps of module jbd
Using modules:  ./kernel/fs/jbd/jbd.ko ./kernel/fs/ext3/ext3.ko
/sbin/nash -> /tmp/initrd.yV2476/bin/nash
/sbin/insmod.static -> /tmp/initrd.yV2476/bin/insmod
copy from /lib/modules/2.6.7-1.517/./kernel/fs/jbd/jbd.ko(elf32-i386)
to /tmp/initrd.yV2476/lib/jbd.ko(elf32-i386)
copy from
/lib/modules/2.6.7-1.517/./kernel/fs/ext3/ext3.ko(elf32-i386) to
/tmp/initrd.yV2476/lib/ext3.ko(elf32-i386)
Loading module jbd
Loading module ext3
[root@localhost ~]# 

Comment 14 Satish Balay 2004-08-12 19:22:57 EDT
Created attachment 102683 [details]
/boot/brub/menu.lst
Comment 15 Jeremy Katz 2004-08-12 21:00:15 EDT
And then boot that initrd?  (it should then say what tries to get
exec'd as init that fails)
Comment 16 James Laska 2004-08-13 09:26:59 EDT
w/ custom /sbin/nash

exec of init (/sbin/init) failed!!!: 14
Comment 17 Satish Balay 2004-08-13 10:25:25 EDT
I get the same message as well:
---
exec of init (/sbin/init) failed!!!: 14
---

And booting without "rhgb quiet" continues to work.
Comment 18 Jeremy Katz 2004-08-13 13:20:18 EDT
Okay added even more debugging printfs to nash's exec of init.  New
nash at http://people.redhat.com/~katzj/nash-test-2.  If you could
grab that and remake your initrd and let me know what output you get,
that would be helpful.
Comment 19 Brian Millett 2004-08-13 14:32:40 EDT
Here is my boot parameters from grub.conf:
kernel /vmlinuz-2.6.7-1.517 ro root=LABEL=/ vga=0x317 rhgb selinux=0 quiet

I got your new nash.  Booted and this is the error:
---BEGIN---
initargs[1] ro
initargs[2] root=LABEL=/
initargs[3] vga=0x317
initargs[4] rhgb
initargs[5] selinux=0
initargs[6] quiet
exec of init (/sbin/init) failed!!!: 14
--END--

Now what I found is that it did not matter if I took out rhgb, quiet,
vga=0x317.  What mattered is if I had < 6 initargs.

args <6 will boot.  args >= 6 no boot.

Hope this helps.
Comment 20 Satish Balay 2004-08-13 15:35:17 EDT
Ok I see the same behavior (args<6 => boot will work) as well. I
currently have:
kernel /vmlinuz-2.6.7-1.517 ro root=LABEL=/ selinux=0 rhgb quiet acpi=off

Removing 'acpi=off' worked.

Screendump with failure is:
----------
Red Hat nash version 4.0.5.1 starting
initargs[1]: r0
initargs[2]: root=LABEL=/
initargs[3]: selinux=0
initargs[4]: rhgb
initargs[5]: quiet
initargs[6]: acpi=off
exec of init (/sbin/init) failed!!!: 14
kernel panic: Attempted to kill init!

---
Comment 21 Jeremy Katz 2004-08-16 13:18:24 EDT
mkinitrd-4.0.6 building with a variety of fixes (will be in the same
place on my people page once its done)
Comment 22 Satish Balay 2004-08-16 17:59:21 EDT
mkinitrd-4.0.6 appears to fix the probem for me. kernel now boots fine
with 6 options.
Comment 23 James Laska 2004-08-17 11:52:36 EDT
mkinitrd-4.0.6 resolves this issue.  Please re-open if the problem
resurfaces in the future.

Note You need to log in before you can comment on or make changes to this bug.