Bug 1296677 - kernel-4.3.3-300.fc23.x86_64 breaks Dell XPS 13 9350's trackpad
kernel-4.3.3-300.fc23.x86_64 breaks Dell XPS 13 9350's trackpad
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 15:01 EST by Andy Lutomirski
Modified: 2016-02-01 01:26 EST (History)
10 users (show)

See Also:
Fixed In Version: kernel-4.3.3-301.fc23 kernel-4.3.3-303.fc23 kernel-4.3.4-300.fc23 kernel-4.3.4-200.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:25:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Lutomirski 2016-01-07 15:01:32 EST
On kernel-4.3.3-300.fc23.x86_64, my Dell XPS 13 9350's trackpad doesn't work reliably (it fails shortly after boot and doesn't come back).  The issue is fixed upstream by this patch, which is unfortunately not tagged for -stable.

commit 6d4f5440a3a2bb2e9d0d582bbf98234e9e9bb095
Author: Mika Westerberg <mika.westerberg@linux.intel.com>
Date:   Wed Oct 7 15:33:43 2015 +0300

    HID: multitouch: Fetch feature reports on demand for Win8 devices
Comment 1 Josh Boyer 2016-01-07 15:06:51 EST
Benjamin, should this be backported?
Comment 2 Benjamin Tissoires 2016-01-08 03:22:05 EST
I think it's fine. Iĺl let Greg know also upstream.
Comment 3 Josh Boyer 2016-01-08 08:12:31 EST
Patch added in Fedora git.  Thanks!
Comment 4 Fedora Update System 2016-01-15 14:25:32 EST
kernel-4.3.3-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a
Comment 5 John Loring 2016-01-15 18:07:22 EST
Said problem also occurs on Dell XPS 15 9550. Although, bug filer states trackpad works at the very beginning. On mine, trackpad does not work at all when booting into OS with said kernel.

When will I be able to update my kernel with 4.3.3-301, with fix as indicated by Comment 4?
Comment 6 Josh Boyer 2016-01-15 18:34:32 EST
It was submitted to updates-testing today.  It should be in updates-testing repos on the mirrors within the next few days.
Comment 7 John Loring 2016-01-15 20:15:28 EST
(In reply to Josh Boyer from comment #6)
> It was submitted to updates-testing today.  It should be in updates-testing
> repos on the mirrors within the next few days.

Thank you.
Comment 8 Fedora Update System 2016-01-17 09:23:28 EST
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a
Comment 9 Fedora Update System 2016-01-19 07:55:23 EST
kernel-4.3.3-302.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-db9fedd7c4
Comment 10 Fedora Update System 2016-01-20 16:52:33 EST
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-01-21 23:58:50 EST
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b59fd603be
Comment 12 John Loring 2016-01-22 08:43:18 EST
I thought version 301 fixed the trackpad bug. What is version 303 supposed to fix?
Comment 13 Josh Boyer 2016-01-22 08:51:08 EST
There were some bodhi issues that caused some update and bugzilla hiccups.  The bug is fixed in -301 _and_ -303.  -303 just has additional unrelated fixes.
Comment 14 John Loring 2016-01-22 08:55:38 EST
Thanks. The reason I ask is because I have another bug report that has been filed (for a system hang issue). I am assuming that a kernel update is pending for that bug fix as well. Thanks again.
Comment 15 Josh Boyer 2016-01-23 22:30:52 EST
We've had several reports of Acer Touchpads breaking in the -301 kernel, which includes this patch.  See the bodhi comments on this update.

Have there been any reported regressions or additional fixes upstream?  I'm going to have to drop this patch with the 4.3.4 kernel if we can't get these fixed.
Comment 16 Benjamin Tissoires 2016-01-24 03:36:38 EST
Hmm, I can't seem to find those comments you are mentioning. Josh, are you sure this patch breaks the Acer systems and not the other ones regarding the designware controller?
Comment 17 Isaque Galdino 2016-01-24 08:26:25 EST
So, this is the guilt one - this bloody Dell :) ! My acer touchpad was working before, until kernel-4.3.3-300, now it doesn't work with the new one anymore:

$ uname -a
Linux xxxx.xxxxxxx 4.3.3-301.fc23.x86_64 #1 SMP Fri Jan 15 14:03:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Thanks.
Comment 18 Josh Boyer 2016-01-24 10:36:11 EST
(In reply to Benjamin Tissoires from comment #16)
> Hmm, I can't seem to find those comments you are mentioning. Josh, are you
> sure this patch breaks the Acer systems and not the other ones regarding the
> designware controller?

https://bodhi.fedoraproject.org/updates/kernel-4.3.3-301.fc23#comment-380386
https://bodhi.fedoraproject.org/updates/kernel-4.3.3-301.fc23#comment-380715
https://bodhi.fedoraproject.org/updates/kernel-4.3.3-301.fc23#comment-380778
https://bodhi.fedoraproject.org/updates/kernel-4.3.3-301.fc23#comment-380882

Unfortunately, I haven't seen an actual bug opened and the comments are sparse.
Comment 19 John Loring 2016-01-24 18:53:33 EST
In response to comment #15, my trackpad has worked ever since the bug fix. Please don't drop the patch with kernel 4.3.4.
Comment 20 Josh Boyer 2016-01-24 20:00:17 EST
(In reply to John Loring from comment #19)
> In response to comment #15, my trackpad has worked ever since the bug fix.
> Please don't drop the patch with kernel 4.3.4.

It's a tough call.  It fixes the touchpad to work for the first time ever on your new machine, but it appears (?) to cause regressions on other machines.  Regressions tend to outweigh new support.

I haven't dropped it yet, so there is still time to fix it.
Comment 21 Andy Lutomirski 2016-01-24 20:30:50 EST
Benjamin, what are the other designware patches you're looking at?  Would it make sense to do a scratch build that one of the affected Acer users could test to help narrow it down?
Comment 22 Benjamin Tissoires 2016-01-25 04:36:33 EST
I did not remembered I already had to fix the Elan panels in the 4.5 kernel.

Josh, could you add
https://git.kernel.org/cgit/linux/kernel/git/jikos/hid.git/commit/?h=for-4.5/multitouch&id=73e7d63efb4d774883a338997943bfa59e127085

To the fedora kernel, with some luck, this will solve the Acer Elan touchpads problems.

(In reply to Andy Lutomirski from comment #21)
> Benjamin, what are the other designware patches you're looking at?  Would it
> make sense to do a scratch build that one of the affected Acer users could
> test to help narrow it down?

Andy, I don't think this is designware related. hid-multitouch binds properly for these panels. The commit I mentioned above is more likely to fix the issues here.
Comment 23 Josh Boyer 2016-01-25 07:55:46 EST
(In reply to Benjamin Tissoires from comment #22)
> I did not remembered I already had to fix the Elan panels in the 4.5 kernel.
> 
> Josh, could you add
> https://git.kernel.org/cgit/linux/kernel/git/jikos/hid.git/commit/?h=for-4.5/
> multitouch&id=73e7d63efb4d774883a338997943bfa59e127085

Gladly.  I'll get it into the 4.3.4 build.
Comment 24 Andy Lutomirski 2016-01-25 12:22:26 EST
Ah, I misunderstood what you (Benjamin) meant.
Comment 25 Fedora Update System 2016-01-25 13:22:21 EST
kernel-4.3.4-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f25d12c51
Comment 26 Fedora Update System 2016-01-25 13:26:07 EST
kernel-4.3.4-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d43766e33
Comment 27 John Loring 2016-01-25 13:27:41 EST
Is the trackpad fix persistent in the 4.3.4-300 kernel update for F23?
Comment 28 Josh Boyer 2016-01-25 13:28:34 EST
Both the XPS fix and the patch Benjamin highlighted are in 4.3.4-300/200.  Testing would be appreciated.
Comment 29 John Loring 2016-01-25 16:55:25 EST
I appreciate your concern for testing. And, I would like to help by testing the update. However, on the same machine I am dealing with a screen brightness issue that if not fixed, very noticeably irritates my eyes. I will say that if I can get the opportunity to test the kernel update, I will do exactly that. I know you work really hard to deliver, and it's a team effort. I will participate in helping to deliver success if I get the opportunity. Much thanks.

In the meantime, do you know if any of the participants in this website (Red Hat Bugzilla) can generate a fix for the dim display/brighten display buttons on my keyboard to work?
Comment 30 Andy Lutomirski 2016-01-25 16:57:55 EST
(In reply to John Loring from comment #29)
> In the meantime, do you know if any of the participants in this website (Red
> Hat Bugzilla) can generate a fix for the dim display/brighten display
> buttons on my keyboard to work?

It would probably make sense to file a separate bug for that.  Including the exact model of your laptop would help, too, as would whatever messages, if any, end up in the kernel log (type 'dmesg | tail') when you press the brightness buttons.

In general, the brightness buttons should work on all laptops.  If they don't, it's a bug.
Comment 31 John Loring 2016-01-25 21:45:44 EST
(In reply to Andy Lutomirski from comment #30)
> (In reply to John Loring from comment #29)
> > In the meantime, do you know if any of the participants in this website (Red
> > Hat Bugzilla) can generate a fix for the dim display/brighten display
> > buttons on my keyboard to work?
> 
> It would probably make sense to file a separate bug for that.  Including the
> exact model of your laptop would help, too, as would whatever messages, if
> any, end up in the kernel log (type 'dmesg | tail') when you press the
> brightness buttons.
> 
> In general, the brightness buttons should work on all laptops.  If they
> don't, it's a bug.

I am in the middle of filing a bug report for the display brightness problem, but the bug report tool is requiring me to select a "Component" for the bug, and I do not know what component to select. Which component should I select for this particular bug (display brightness not working on keyboard)? Thanks.
Comment 32 Andy Lutomirski 2016-01-25 21:55:25 EST
(In reply to John Loring from comment #31)
> 
> I am in the middle of filing a bug report for the display brightness
> problem, but the bug report tool is requiring me to select a "Component" for
> the bug, and I do not know what component to select. Which component should
> I select for this particular bug (display brightness not working on
> keyboard)? Thanks.

'kernel'
Comment 33 John Loring 2016-01-25 21:58:19 EST
(In reply to Andy Lutomirski from comment #32)
> (In reply to John Loring from comment #31)
> > 
> > I am in the middle of filing a bug report for the display brightness
> > problem, but the bug report tool is requiring me to select a "Component" for
> > the bug, and I do not know what component to select. Which component should
> > I select for this particular bug (display brightness not working on
> > keyboard)? Thanks.
> 
> 'kernel'

I was just about to tell you "never mind, I just used 'kernel'", and then I saw your reply. Nonetheless, I believe I filed an accurate and helpful bug on that. Thanks for your assistance.
Comment 34 Fedora Update System 2016-01-25 23:22:06 EST
kernel-4.3.4-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d43766e33
Comment 35 Fedora Update System 2016-01-25 23:27:41 EST
kernel-4.3.4-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2f25d12c51
Comment 36 Fedora Update System 2016-01-26 13:23:30 EST
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 37 Isaque Galdino 2016-01-27 11:05:02 EST
$ uname -a
Linux fred.bedrock 4.3.3-303.fc23.x86_64 #1 SMP Tue Jan 19 18:31:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

touchpad still not working.
Comment 38 Josh Boyer 2016-01-27 12:52:44 EST
Please try 4.3.4-300 in updates-testing.
Comment 39 Isaque Galdino 2016-01-27 16:10:01 EST
$ uname -a
Linux fred.bedrock 4.3.4-300.fc23.x86_64 #1 SMP Mon Jan 25 13:39:23 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Acer touchpad works fine, so:

kernel-4.3.3-300 OK
kernel-4.3.3-301 NOT OK
kernel-4.3.3-303 NOT OK
kernel-4.3.4-300 OK
Comment 40 Fedora Update System 2016-01-31 21:22:15 EST
kernel-4.3.4-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 41 Fedora Update System 2016-02-01 01:22:55 EST
kernel-4.3.4-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.