Bug 1296688 - yum updateinfo lists errata/packages even on a fully updated rhel 7 content host
yum updateinfo lists errata/packages even on a fully updated rhel 7 content host
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 15:57 EST by sthirugn@redhat.com
Modified: 2018-01-03 07:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-03 07:13:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2016-01-07 15:57:28 EST
Description of problem:
yum updateinfo lists errata/packages even on a fully updated rhel 7 content host

Version-Release number of selected component (if applicable):
Satellite 6.1.5

How reproducible:
Always

Steps to Reproduce:
1. Sync rhel 7 x86_64 repo in satellite, create content view, link the repo, publish, promote to right environments.  Add a subscription and create an activation key.  Link the activation key with the content view and subscription.
2. Register and subscribe a rhel 7 content host to satellite:
[content-host]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)
3. Update the content host:
[content-host]# yum update
4. Run yum updateinfo:
[content-host]# yum updateinfo
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
rhel-7-server-rpms/7Server/x86_64                                                                                                                             | 2.5 kB  00:00:00     
Updates Information Summary: available
    3 Bugfix notice(s)
    3 Enhancement notice(s)
updateinfo summary done


[content-host]# yum updateinfo list
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
rhel-7-server-rpms/7Server/x86_64                                                                                                                             | 2.5 kB  00:00:00     
RHBA-2015:2147 bugfix      device-mapper-7:2.02.130-5.el7.x86_64
RHBA-2015:2147 bugfix      device-mapper-event-7:2.02.130-5.el7.x86_64
RHBA-2015:2147 bugfix      device-mapper-event-libs-7:2.02.130-5.el7.x86_64
RHBA-2015:2147 bugfix      device-mapper-libs-7:2.02.130-5.el7.x86_64
RHEA-2015:2123 enhancement iwl100-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl1000-firmware-1:20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl105-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl135-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl2000-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl2030-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl3160-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl3945-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl4965-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl5000-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl5150-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl6000-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl6000g2a-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl6000g2b-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl6050-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl7260-firmware-20150904-43.git6ebf5d5.el7.noarch
RHEA-2015:2123 enhancement iwl7265-firmware-20150904-43.git6ebf5d5.el7.noarch
RHBA-2015:2374 bugfix      libbasicobjects-0.5.0-25.el7.x86_64
RHBA-2015:2374 bugfix      libpath_utils-0.5.0-25.el7.x86_64
RHBA-2015:2374 bugfix      libref_array-0.5.0-25.el7.x86_64
RHEA-2015:0518 enhancement linux-firmware-1:20140911-0.1.git365e80c.el7.noarch
RHBA-2015:2113 bugfix      perl-CPAN-5.16.3-286.el7.noarch
RHBA-2015:2113 bugfix      perl-ExtUtils-Install-5.16.3-286.el7.noarch
RHBA-2015:2113 bugfix      perl-Pod-Escapes-1:5.16.3-286.el7.noarch
RHEA-2015:1863 enhancement tzdata-2015g-2.el6.noarch
updateinfo list done

[content-host]# yum update
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
rhel-7-server-rpms                                                                                                                                            | 2.5 kB  00:00:00     
No packages marked for update


Actual results:
`yum updateinfo` on a fully updated content host lists available errata.

Expected results:
`yum updateinfo` on a fully updated content host should not list any available errata.

Additional info:
Comment 1 sthirugn@redhat.com 2016-01-07 15:59:00 EST
One errata entry in the list - `RHEA-2015:1863 enhancement tzdata-2015g-2.el6.noarch` is a rhel6 errata so I think this specific one is related to https://bugzilla.redhat.com/show_bug.cgi?id=1266072 but the other errata are all rhel 7 ones.
Comment 5 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 6 Bryan Kearney 2016-07-26 11:37:20 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 11 Justin Sherrill 2017-12-18 11:39:48 EST
At first this sounded like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1255875

However, when examining the output of the 'yum updateinfo' some things stood out.  Take these 3 lines/errata:


RHBA-2015:2147 bugfix      device-mapper-7:2.02.130-5.el7.x86_64
RHBA-2015:2374 bugfix      libref_array-0.5.0-25.el7.x86_64
RHBA-2015:2113 bugfix      perl-CPAN-5.16.3-286.el7.noarch

In all 3 cases, if you look at the errata information on the support portal, you will see that the packages specified by yum aren't actually included in them and there is something awfully suspicious going on.  

In each of these cases, the version of the package doesn't exist, but some OTHER package in that errata has that version.  Take RHBA-2015:2147  for example, it does not include:

device-mapper-7:2.02.130-5.el7.x86_64, instead it includes device-mapper-1.02.107-5.el7.x86_64.rpm

However, it DOES include lvm2-2.02.130-5.el7  (the same release and version as the mistaken package version).

So either:

a) the cdn messed up and put things in the errata incorrectly
or
b) pulp messed up and messed up the creation of the errata during syncing

There is no way to tell from the included data.  Is the issue still reproducible?  and do you have a reproducer?
Comment 12 sthirugn@redhat.com 2018-01-02 12:05:30 EST
@Justin, I haven't seen this issue lately.

@jalviso, have you seen this in recent testing? or do you happen to have a reproducer?

If not, I think we need to close this one out and reopen if we see this again.
Comment 13 jalviso 2018-01-03 02:32:50 EST
Hi,

On a newly updated RHEL7 (using a newly synced/published/promoted Default Organization View) registered to Sat6.2.12, I can no longer see this issue;

# yum updateinfo
Loaded plugins: product-id, search-disabled-repos, subscription-manager
rhel-7-server-rpms/7Server/x86_64                                                                               | 2.0 kB  00:00:00     
Security: kernel-3.10.0-693.11.1.el7.x86_64 is an installed security update
Security: kernel-3.10.0-693.el7.x86_64 is the currently running version
updateinfo summary done     <==== here, i haven't rebooted the vm yet
[root@sat63-test-12 ~]# yum updateinfo list
Loaded plugins: product-id, search-disabled-repos, subscription-manager
rhel-7-server-rpms/7Server/x86_64                                                                               | 2.0 kB  00:00:00     
updateinfo list done

Regards,

Josephine Alviso
GSS - APAC
Comment 14 Justin Sherrill 2018-01-03 07:13:38 EST
Thanks Josephine!  I'll go ahead and close this.  If you see any more customers hitting this please feel free to reopen

Note You need to log in before you can comment on or make changes to this bug.