Bug 1296709 - Library files /usr/lib64/libusb-1.0.so and /usr/lib64/libssl.so are missing
Library files /usr/lib64/libusb-1.0.so and /usr/lib64/libssl.so are missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libusb (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 18:40 EST by Jonathan Ryshpan
Modified: 2016-01-09 13:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 14:33:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Ryshpan 2016-01-07 18:40:26 EST
Description of problem:
Library files /usr/lib64/libusb-1.0.so  and /usr/lib64/libssl.so are missing from the Fedora-23 distribution.  


Version-Release number of selected component (if applicable):
RPMs libusbx-1.0.20-1.fc23.x86_64 and openssl-libs-1.0.2e-3.fc23.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Link anything needing to -lusb-1.0 or -lssl


Actual results:
Link fails


Expected results:
Link succeeds


Additional info:
Cured on my system by
   # cd /usr/lib64
   # ln -s libusb-1.0.so.0.1.0 libusb-1.0.so
   # ln -s libssl.so.1.0.2e libssl.so
Comment 1 Hans de Goede 2016-01-08 14:33:30 EST
Hi,

(In reply to Jonathan Ryshpan from comment #0)
> Library files /usr/lib64/libusb-1.0.so  and /usr/lib64/libssl.so are missing
> from the Fedora-23 distribution.  

They are not missing you just need to install the right -devel packages to get them:

[hans@shalem llvm]$ rpm -qf /usr/lib64/libusb-1.0.so /usr/lib64/libssl.so
libusbx-devel-1.0.20-1.fc23.x86_64
openssl-devel-1.0.2e-3.fc23.x86_64

So "dnf install libusbx-devel openssl-devel" should fix this for you.

Regards,

Hans
Comment 2 Jonathan Ryshpan 2016-01-09 02:53:40 EST
(In reply to Hans de Goede from comment #1)
> Hi,
> 
> (In reply to Jonathan Ryshpan from comment #0)
> > Library files /usr/lib64/libusb-1.0.so  and /usr/lib64/libssl.so are missing
> > from the Fedora-23 distribution.  
> 
> They are not missing you just need to install the right -devel packages to
> get them:
> 
> [hans@shalem llvm]$ rpm -qf /usr/lib64/libusb-1.0.so /usr/lib64/libssl.so
> libusbx-devel-1.0.20-1.fc23.x86_64
> openssl-devel-1.0.2e-3.fc23.x86_64
> 
> So "dnf install libusbx-devel openssl-devel" should fix this for you.

Quite right, and since I was developing I should have thought to install these packages.  

Nevertheless it seems odd that libusbx contains 
  /usr/lib64/libusb-1.0.so.0
  /usr/lib64/libusb-1.0.so.0.1.0
while libusbx-devel contains
  /usr/lib64/libusb-1.0.so

and similarly openssl-libs contains
  /usr/lib64/libssl.so.1.0.2e
  /usr/lib64/libssl.so.10
while openssl-libs contains
  /usr/lib64/libssl.so

Is there a reason for this, or is it just the way things are?
Comment 3 Hans de Goede 2016-01-09 06:35:48 EST
(In reply to Jonathan Ryshpan from comment #2)
> Is there a reason for this, or is it just the way things are?

The .so symlinks are only needed to link a binary while building it, where as the foo.so.x symlink is actually used to resolve runtime linking.

Since the .so is only used for compiling it goes in to the -devel pkg together with e.g. the .h and .pc files.
Comment 4 Jonathan Ryshpan 2016-01-09 13:06:43 EST
(In reply to Hans de Goede from comment #3)
> (In reply to Jonathan Ryshpan from comment #2)
> > Is there a reason for this, or is it just the way things are?
> 
> The .so symlinks are only needed to link a binary while building it, where
> as the foo.so.x symlink is actually used to resolve runtime linking.
> 
> Since the .so is only used for compiling it goes in to the -devel pkg
> together with e.g. the .h and .pc files.

I learn a little every day.

Thanks - jon

Note You need to log in before you can comment on or make changes to this bug.