Bug 1296725 - Please relax permissions on auditd and auditctl
Please relax permissions on auditd and auditctl
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 20:19 EST by Andy Lutomirski
Modified: 2016-03-18 11:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-18 11:43:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Lutomirski 2016-01-07 20:19:46 EST
Per FPC ticket #467 (https://fedorahosted.org/fpc/ticket/467), these programs should be world-readable.  Please set the modes to 4755 instead of 4750.
Comment 1 Steve Grubb 2016-01-19 13:31:54 EST
The reason that these files have the permissions they do is because of common criteria requirements. I try to keep Fedora and RHEL closely sync'ed to cut down excess work and potential mistakes. To open the permissions I need to go add if(geteuid!=0) _exit(1); all over the place.
Comment 2 Steve Grubb 2016-01-19 13:49:21 EST
Also, I'm curious about something, is this being requested because of containers? Is auditd being 755 all you need?
Comment 3 Andy Lutomirski 2016-01-19 14:10:46 EST
I want it for virtme, which is like a container, although it uses different technology under the hood.  I actually care about auditctl being world-readable more than auditd, but both would be nice.

I use capability to test audit-affecting kernel changes, among other things.
Comment 4 Steve Grubb 2016-01-19 14:24:35 EST
OK. I think I can relax the permissions on those two. I'll make the change in git and the next time rawhide gets a rebuild, it'll be pushed out.
Comment 5 Jan Kurik 2016-02-24 09:14:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Steve Grubb 2016-03-18 11:43:20 EDT
New packages have been pushed out for a month or two. I am closing this under the assumption that its working fine.

Note You need to log in before you can comment on or make changes to this bug.