Bug 1296726 - Provide an overview of how to configure and use remote management
Provide an overview of how to configure and use remote management
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
Unspecified
Unspecified Unspecified
high Severity high (vote)
: Beta
: 6.2
Assigned To: Peter Ondrejka
Stephen Wadeley
:
Depends On: 1052273
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 20:32 EST by Andrew Dahms
Modified: 2016-06-16 19:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Remote Management. Reason: New for 6.2 and at least basics required for Beta. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 19:43:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2016-01-07 20:32:53 EST
In Red Hat Satellite 6.2, it is now possible to schedule tasks on client machines. This is known as remote management.

A conceptual overview of remote management and procedures that outline how to configure and then work with this functionality must be added to the documentation.
Comment 2 Bryan Kearney 2016-01-07 22:04:31 EST
Upstream bug component is Remote Actions
Comment 3 Bryan Kearney 2016-01-07 22:04:33 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/10760 has been closed
Comment 6 Andrew Dahms 2016-01-11 22:51:19 EST
Moving back to the documentation component.
Comment 7 David O'Brien 2016-01-11 23:10:31 EST
http://theforeman.org/plugins/foreman_remote_execution/0.1/index.html

Starting point
Comment 12 David O'Brien 2016-01-31 19:26:17 EST
http://theforeman.org/plugins/foreman_remote_execution/nightly/index.html#2.Installation

wrt the above, what's the Sat6 equivalent of foreman-installer? Is that a viable option for Sat6, or should we only document manual installation? I also want to double-check because I know there was talk of renaming the installer commands in satellite 6.2.

Seems like a basic question but I don't have a test env available atm to test these things.
Comment 14 David O'Brien 2016-01-31 22:46:53 EST
Is the following instruction valid for Sat6.2 or do we need to configure something else?

http://theforeman.org/manuals/1.10/index.html#2.Quickstart

yum-config-manager --enable rhel-6-server-optional-rpms rhel-server-rhscl-6-rpms

I already have rhscl-6 but don't know about optional. That command doesn't appear to enable the repo. It doesn't appear in yum repolist. Did I miss something? I expect if I get this sorted it will answer Comment 12
Comment 15 David O'Brien 2016-02-01 00:54:10 EST
(In reply to David O'Brien from comment #14)
> Is the following instruction valid for Sat6.2 or do we need to configure
> something else?
> 
> http://theforeman.org/manuals/1.10/index.html#2.Quickstart
> 
> yum-config-manager --enable rhel-6-server-optional-rpms
> rhel-server-rhscl-6-rpms
> 
> I already have rhscl-6 but don't know about optional. That command doesn't
> appear to enable the repo. It doesn't appear in yum repolist. Did I miss
> something? I expect if I get this sorted it will answer Comment 12

ok, scratch this one. Use subscription-manager

subscription-manager repos --enable rhel-6-server-optional-rpms

But, I still get stuck here:

Enable the EPEL (Extra Packages for Enterprise Linux) and the Foreman repos:

`rpm -ivh http://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm`
`yum -y install http://yum.theforeman.org/releases/1.10/el6/x86_64/foreman-release.rpm`

Is this something we should be doing on a Satellite Server or Capsule? I'm guessing no, but don't know what the equivalent is. I'm pretty sure the second bit is already taken care of, but I still don't know where to get foreman-installer, or if I even need it.

Feel free to schedule an irc session to go over a few things if that'd be easier.
Comment 17 David O'Brien 2016-02-02 00:56:33 EST
Is "job" a common and accepted term, and something we want to stick
with, when referring to jobs/tasks/whatever on remote hosts?

See
http://theforeman.org/plugins/foreman_remote_execution/0.2/index.html#4.
1Determiningthesmartproxyforhost

"In order to perform the job on a host, there needs to be a Smart
Proxy available to do the job."

What exactly constitutes a "job"? Is it just a command? A group or
sequence of commands? A script? Any of the above?

I know "cronjob" is perfectly legitimate, but I don't know if this is
the preferred term for Remote Management.

ta
Comment 18 Ivan Necas 2016-02-02 06:29:23 EST
The job represents the script executed against a set of hosts. The template of the script is called 'Job Template'. The job is how we call it in the Remote Execution. If some other term is preferred, we would need to update the code firs.
Comment 19 David O'Brien 2016-02-02 20:00:19 EST
Based on feedback from various sources, staying with "Job".

Still need-info on Comment 15 and Comment 16
Comment 20 David O'Brien 2016-02-02 20:14:57 EST
No objections or alternatives offered so going ahead as planned and putting this in the User Guide.
Comment 21 David O'Brien 2016-02-02 20:59:42 EST
commit 4302a866fce14e170e5afd044b88599fb7b47066
Author: David O'Brien <daobrien@redhat.com>
Date:   Wed Feb 3 11:57:05 2016 +1000

    bz1296726 Update section on Advanced Config

    Start fleshing out advanced config options for remote management, in
    this case how to specify which capsule to use.
Comment 23 David O'Brien 2016-02-03 21:43:39 EST
From Ivan on foreman-dev:

As with all settings in 'Admin -> Settings' section, they can be pre-configured in /etc/foreman/settings.yaml. However, since we don't expose this options to the installer, the manual changes to the file would be overriten  by the next run of the installer. Therefore the 'Admin -> Settings' (or `foreman-rake config` from a console) are preferable).
Comment 24 David O'Brien 2016-02-03 21:47:34 EST
Based on foreman-dev comments it seems s/Remote Management/Remote Execution/ is happening.

Need to make sure we're consistent in the doc.
Comment 25 David O'Brien 2016-02-03 21:48:59 EST
Followed up outstanding need-info requests on doc/dev sync this morning and cbillett is going to give things a push.
Comment 26 David O'Brien 2016-02-04 00:05:17 EST
[bz1296726 a9c8dfb] bz1296726 Describe consequences of manual updates to config.
Comment 27 David O'Brien 2016-02-04 00:55:04 EST
http://theforeman.org/plugins/foreman_remote_execution/0.2/index.html#4.3Permissiondelegation

There are a few examples at the end of this section but I can't tell if they apply to delegation in general, or only to execute_template_invocation

When I get the thing installed myself I should be able to work it out.
Comment 28 David O'Brien 2016-02-04 00:55:26 EST
[bz1296726 5eda3c2] bz1296726 Add section on delegating permissions.
Comment 29 David O'Brien 2016-02-04 18:45:38 EST
Cancelling need-info for now. No 6.2 builds available so will try to get a katello install done to test stuff.
Comment 31 David O'Brien 2016-02-09 23:03:08 EST
Note that this is now called Remote Execution and not Remote Management.
Comment 34 Andrew Dahms 2016-03-02 10:15:39 EST
Assigning Stephen as the QA contact.
Comment 35 David O'Brien 2016-03-09 23:40:51 EST
Been trying to get rex to work with snap2 server and separate host on laptops but so far it fails. Emailed sat6 list for info. dmac is going to try when he gets a later build installed (later today?).
Comment 36 David O'Brien 2016-03-10 21:42:06 EST
Eventually found some missing bits and pieces (packages not installed by installer, ssh key not copied, etc.), and sorted them out. Not sure what the status will be by GA but can make it work now.
Comment 40 David O'Brien 2016-03-17 23:35:51 EDT
There is a demo here:

http://theforeman.org/plugins/foreman_remote_execution/0.1/index.html

It shows how to view the output of job in real time. The buttons are a little different in Sat6.2 (on the Hosts tab the Actions column has "Host Detail" and not "Details"). If you click Host Detail you get exactly that - details about the host - and not live output of the job.

I don't see how to make this work.
Comment 41 David O'Brien 2016-03-18 00:40:43 EDT
(In reply to David O'Brien from comment #40)
> There is a demo here:
> 
> http://theforeman.org/plugins/foreman_remote_execution/0.1/index.html
> 
> It shows how to view the output of job in real time. The buttons are a
> little different in Sat6.2 (on the Hosts tab the Actions column has "Host
> Detail" and not "Details"). If you click Host Detail you get exactly that -
> details about the host - and not live output of the job.
> 
> I don't see how to make this work.

ok, worked it out. You need to click the name of the host that you want to inspect.
Comment 42 David O'Brien 2016-03-18 00:47:49 EDT
In the section Monitoring the Remote Job I added a screenshot of how the output looks. I'm  not sure how valuable this is atm, and it also has IP addresses in it. Future uncertain...
Comment 49 Ivan Necas 2016-04-05 03:59:59 EDT
I went over the docs and it looks good now. ACK

As for the definite list, https://bugzilla.redhat.com/show_bug.cgi?id=1323658 covers it pretty well "(bulk actions on content hosts, package install, errata install)" so it's pakage and errata actions and it's either from single content host, or from the bulk actions
Comment 57 Andrew Dahms 2016-04-27 19:43:53 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.