Bug 1296821 - Missing config(noreplace) macro for /etc/pam.d/samba in the spec file
Missing config(noreplace) macro for /etc/pam.d/samba in the spec file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Andreas Schneider
Robin Hack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 03:38 EST by Jakub Hradil
Modified: 2016-11-04 02:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: samba-4.4.4-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:58:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hradil 2016-01-08 03:38:22 EST
Description of problem:
After updating samba, the custom changes made in /etc/pam.d/samba are lost. This is due to config(noreplace) macro not being used for this file in the spec file.


Version-Release number of selected component (if applicable):
samba-4.1.12

How reproducible:
Always

Steps to Reproduce:
1. Modify /etc/pam.d/samba
2. Run yum upgrade samba (assuming update is available)
3. See customized /etc/pam.d/samba replaced by the one distributed in rpm

Actual results:
/etc/pam.d/samba is always replaced by the one provided by the rpm package.

Expected results:
/etc/pam.d/samba should be kept intact, so that custom changes are retained.

Additional info:
Comment 6 errata-xmlrpc 2016-11-04 02:58:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2468.html

Note You need to log in before you can comment on or make changes to this bug.