Bug 1296844 - RDO Kilo packstack AIO install fails on CentOS 7.2. Error: Unable to connect to mongodb server! (192.169.142.54:27017)
RDO Kilo packstack AIO install fails on CentOS 7.2. Error: Unable to connect ...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Kilo
x86_64 Linux
unspecified Severity medium
: ---
: Kilo
Assigned To: Martin Magr
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 04:14 EST by Boris Derzhavets
Modified: 2016-05-19 04:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-packstack-8.0.0-0.7.0rc2.el7.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-19 04:20:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 181294 None None None 2016-05-19 04:20 EDT

  None (edit)
Description Boris Derzhavets 2016-01-08 04:14:30 EST
Description of problem:
Running packstack --allinone get failure

Applying 192.169.142.54_redis.pp
192.169.142.54_mongodb.pp:                        [ ERROR ]          
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.169.142.54_mongodb.pp
Error: Unable to connect to mongodb server! (192.169.142.54:27017)

Version-Release number of selected component (if applicable):

[root@ip-192-169-142-54 ~(keystone_admin)]# nova-manage version
2015.1.1-1.el7

[root@ip-192-169-142-54 ~(keystone_admin)]# rpm -qa | grep openstack-packstack
openstack-packstack-puppet-2015.1-0.14.dev1616.g5526c38.el7.noarch
openstack-packstack-2015.1-0.14.dev1616.g5526c38.el7.noarch

How reproducible:

Download rdo-release-kilo-1.noarch.rpm
rpm -iv rdo-release-kilo-1.noarch.rpm
yum -y install openstack-packstack
Run packstack --allinone on CentOS 7.2

Steps to Reproduce:

1. Download rdo-release-kilo-1.noarch.rpm
2. rpm -iv rdo-release-kilo-1.noarch.rpm
3. yum -y install openstack-packstack
4. packstack --allinone ( on CentOS 7.2 )



Actual results:

192.169.142.54_mongodb.pp:                        [ ERROR ]          
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.169.142.54_mongodb.pp
Error: Unable to connect to mongodb server! (192.169.142.54:27017)


Expected results:

Successful install

Additional info:

Workaround (to bind to host IP, actually binds to 127.0.0.1 )

systemctl stop mongod.service
rm -f /etc/mongodb.conf
ln -s /etc/mongod.conf /etc/mongodb.conf
Rerun packstack
Comment 1 Boris Derzhavets 2016-01-08 05:15:30 EST
I attempted patch suggested in
http://arctton.blogspot.com/2015/04/rdo-juno-packstack-deploy-failed-with.html
It doesn't work for me on RDO Kilo, binding to 127.0.0.1 is still in place.

Symlinking mongodb.conf ( workaround ) gives, what is required :-

[root@ip-192-169-142-54 ~]# netstat -antp | grep mongod
tcp        0      0 192.169.142.54:27017    0.0.0.0:*               LISTEN      30470/mongod        
tcp        0      0 192.169.142.54:27017    192.169.142.54:47861    ESTABLISHED 30470/mongod        
tcp        0      0 192.169.142.54:27017    192.169.142.54:47567    ESTABLISHED 30470/mongod        
tcp        0      0 192.169.142.54:27017    192.169.142.54:47488    ESTABLISHED 30470/mongod        
tcp        0      0 192.169.142.54:27017    192.169.142.54:47575    ESTABLISHED 30470/mongod        

[root@ip-192-169-142-54 ~]# ps -ef | grep 30470
mongodb  30470     1  0 11:47 ?        00:00:07 /usr/bin/mongod --quiet -f /etc/mongodb.conf run
[root@ip-192-169-142-54 ~]#
Comment 3 Javier Peña 2016-05-19 04:20:57 EDT
There were a number of patches to clean up the mongodb configuration, caused by packaging differences between RDO and Red Hat OpenStack Platform (the latest one was https://review.openstack.org/181294). This is currently known to work properly with RDO Mitaka, so I'm closing the bug as CURRENTRELEASE.

Please feel free to reopen the bug if the issue is still relevant in the current RDO release.

Note You need to log in before you can comment on or make changes to this bug.