Bug 1296875 - Package in EPEL7 is 0.9.7 when 1.0.10 is now available in Fedora
Package in EPEL7 is 0.9.7 when 1.0.10 is now available in Fedora
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: python-sqlalchemy (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 05:14 EST by Yanis Guenane
Modified: 2016-01-29 03:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-23 14:10:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanis Guenane 2016-01-08 05:14:32 EST
A new version of python-sqlalchemy has been packaged in Fedora[1]. It would be nice to have it also in EPEL.

I have uploaded some files, if someone is willing to review them to proceed with the update

* SRPM:
https://pub.yanisguenane.fr/fedora/packaging/python-sqlalchemy/python-sqlalchemy-1.0.10-1.el7.centos.src.rpm

* SPEC:
https://pub.yanisguenane.fr/fedora/packaging/python-sqlalchemy/python-sqlalchemy.spec

* RPM:
https://pub.yanisguenane.fr/fedora/packaging/python-sqlalchemy/python-sqlalchemy-1.0.10-1.el7.centos.x86_64.rpm

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=705050

Note. This version(1.0+) is necessary in order to bring a recent version of python-sqlalchemy-utils in EPEL 7
Comment 1 Yanis Guenane 2016-01-08 05:47:13 EST
If that helps : https://koji.fedoraproject.org/koji/taskinfo?taskID=12464688
Comment 2 Pierre-YvesChibon 2016-01-13 04:09:20 EST
I do not really know what to do for this.

On the one side, EPEL does not like pushing update of major release and going to sqlalchemy 1.0.10 would be.
On the other side, sqlalchemy is normally pretty good at backward compatibility. But since I haven't been into the details, I do not know how much this is true between 0.9.7 and 1.0.10.

Note: SQLalchemy-utils is more fragile than sqlalchemy itself, so pushing updates of SA-utils to EPEL might become tricky/trickier in the future.
Comment 3 Kevin Fenzi 2016-01-13 21:40:54 EST
I'd be ok pushing 1.0.11 (current) and letting it stay in testing for a while. 

I think upstream is pretty good about compatibility, so if we ran into something they might well fix it.
Comment 4 Yanis Guenane 2016-01-14 03:04:29 EST
Read on the changelog page[1]

> Please carefully review the sections on behavioral changes for potentially backwards-incompatible changes in behavior.

After looking deeper at the changelog I couldn't find any change really backward-incompatible except eventually this one[2] (Second snippet).

[1] http://docs.sqlalchemy.org/en/latest/changelog/migration_10.html
[2] http://docs.sqlalchemy.org/en/latest/changelog/migration_10.html#postgresql-has-table-now-works-for-temporary-tables
Comment 5 Kevin Fenzi 2016-01-16 15:10:35 EST
ok. I made a scratch build: 

https://koji.fedoraproject.org/koji/taskinfo?taskID=12579891

can you do a bit of testing with that, and if it looks ok, I can build and push to testing.
Comment 6 Yanis Guenane 2016-01-19 06:45:14 EST
Hey Kevin,

> can you do a bit of testing with that, and if it looks ok, I can build and push to testing.

We ran our application with the build you provided and everything is working as expected. I don't mean to use we cover all the features of SA but for our use case it's a go. Thanks for taking care of it.
Comment 7 Yanis Guenane 2016-01-19 06:46:57 EST
s/don't mean to use/don't mean to pretend
Comment 8 Fedora Update System 2016-01-19 16:42:05 EST
python-sqlalchemy-1.0.11-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c1eb98d18b
Comment 9 Fedora Update System 2016-01-21 00:22:28 EST
python-sqlalchemy-1.0.11-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c1eb98d18b
Comment 10 Tuomo Soini 2016-01-21 13:08:19 EST
python-sqlalchemy-0.9.8-1.el7 is part of rhel so please remove package from epel and block it.
Comment 11 Kevin Fenzi 2016-01-22 13:36:53 EST
Sigh. Right you are. ;( 

Will get it retired...
Comment 12 Kevin Fenzi 2016-01-23 14:10:27 EST
Strangely, it's in both rhel7-server AND rhel7-server-extras (I sure hope RH keeps them in sync). 

Anyhow, I have unpushed this update and retired this package in epel7. 

yguenane@redhat.com: can you re-file your request against the rhel7 version of the package and see if they want to update it there?
Comment 13 Yanis Guenane 2016-01-29 03:36:08 EST
kevin@scrye.com: will do that.

Sorry for the confusion here :(
I will be more careful next time.

Note You need to log in before you can comment on or make changes to this bug.