Bug 1296887 - xfreerdp crashes while connecting to windows machine with sound plugin add latency option set
xfreerdp crashes while connecting to windows machine with sound plugin add la...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: freerdp (Show other bugs)
6.7
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 05:59 EST by Tomas Hudziec
Modified: 2016-05-18 05:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: freerdp-1.0.2-4.el6
Doc Type: Bug Fix
Doc Text:
Cause: Sound redirection plugin expects that pulseaudio device is specified on commandline in some cases. Consequence: Freerdp might be terminated unexpectedly due to accessing uninitialized variable if pulseaudio device is not specified. Fix: The plugin checks whether device is specified with this fix. Result: No more crashes if pulseaudio device is not specified on commandline.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:44:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hudziec 2016-01-08 05:59:26 EST
Description of problem:
xfreerdp crashes while connecting to windows machine with sound plugin add latency option set

Version-Release number of selected component (if applicable):
freerdp-1.0.2-3.el6.x86_64
freerdp-libs-1.0.2-3.el6.x86_64
freerdp-plugins-1.0.2-3.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
Try to connect to windows xp machine via xfreerdp :
$ xfreerdp --plugin rdpsnd --data pulse latency:100 -- $WindowsIP

Actual results:
xfreerdp crashes - segmentation fault

Expected results:
xfreerdp should connect to windows machine.


Additional info:
Comment 2 Ondrej Holy 2016-01-08 07:55:33 EST
There isn't problem with "latency", but with parsing of "pulse". See RHEL 7 Bug 1067543 for more details and possible workarounds. There is also link for upstream patch to fix parsing.

This is basically duplicate of Bug 988307 (RHEL 7) and Bug 988272 (RHEL 6), however previous solution was man page modification, but it is not sufficient obviously...
Comment 7 errata-xmlrpc 2016-05-10 15:44:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0756.html

Note You need to log in before you can comment on or make changes to this bug.