Bug 1296927 - [DOCS] NO_PROXY should have correct hostname
[DOCS] NO_PROXY should have correct hostname
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Ashley Hardin
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 08:08 EST by Jaspreet Kaur
Modified: 2016-05-02 09:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-02 09:52:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaspreet Kaur 2016-01-08 08:08:31 EST
Document URL: https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#working-with-http-proxies

Section Number and Name: 12.2. Configuring Hosts for Proxies

Describe the issue: Since the documentation mentions the hostname of master to br added to /etc/sysconfig/atomic-openshift-master

NO_PROXY=master.hostname.example.com

It fails with below error when using "oc log" or "oc exec" since logs and exec are connections made from the client to the master
then the master connects to the kubelet running on the relevant node. 

Error from server: Get https://node.example.com:10250/containerLogs/ng-demo/aa-demo-4-dnq2r/aa-demo: Service Unavailable

Suggestions for improvement: Since the environment can have many nodes so the best way to rectify the situation is to use  wildcard, ie: NO_PROXY=*.example.com

Additional information:
Comment 1 Jaspreet Kaur 2016-01-08 08:36:33 EST
It works with NO_PROXY=.example.com and not with *.example.com
Comment 2 Jaspreet Kaur 2016-03-31 06:41:46 EDT
There is no mention what should be added in case of HA Environment.

What is the role of adding Proxy in below files :

 /etc/sysconfig/atomic-openshift-master-api and /etc/sysconfig/atomic-openshift-master-controller file

Please be clear in the documenation as it does effect in case of importing image streams.

Regards,
Jaspreet
Comment 3 Ashley Hardin 2016-04-11 11:24:45 EDT
@Andrew @Jordan,
Most of what this BZ needs is addressed in this PR: https://github.com/openshift/openshift-docs/pull/1864. However, I'm not sure how to address Jaspreet's last comment. Can you please offer guidance, or help point me in the right direction? Thanks!
Comment 4 Andrew Butcher 2016-04-11 14:47:58 EDT
I think Jaspreet is requesting that we add the specific sysconfig files that must be updated in this section. These paths will be different on origin and enterprise so they should be conditionalized.

Origin
Single master configuration: /etc/sysconfig/origin-master
Multi-master configuration:  /etc/sysconfig/origin-master-api
                             /etc/sysconfig/origin-master-controllers
Node configuration:          /etc/sysconfig/origin-node

Enterprise
Single master configuration: /etc/sysconfig/atomic-openshift-master
Multi-master configuration:  /etc/sysconfig/atomic-openshift-master-api
                             /etc/sysconfig/atomic-openshift-master-controllers
Node configuration:          /etc/sysconfig/atomic-openshift-node

The steps for restarting masters will be different for multi-master installations as well.

Origin
systemctl restart origin-master-controllers
systemctl restart origin-master-api

Enterprise
systemctl restart atomic-openshift-master-controllers
systemctl restart atomic-openshift-master-api
Comment 5 Ashley Hardin 2016-04-12 16:12:38 EDT
Work in progress: https://github.com/openshift/openshift-docs/pull/1889
Comment 6 Ashley Hardin 2016-04-12 16:14:09 EDT
@Jaspreet Please review and let me know what you think: https://github.com/openshift/openshift-docs/pull/1889. 

Related work is here: https://github.com/openshift/openshift-docs/pull/1864
Comment 7 Ashley Hardin 2016-04-22 09:22:51 EDT
Approved by Jaspreet via e-mail.
Comment 8 openshift-github-bot 2016-04-22 09:29:57 EDT
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/39d9ddcd1d819d7701535d2f6ef4ab2842c57090
Bug 1296927, added specific sysconfig files

https://github.com/openshift/openshift-docs/commit/48358e1daa947518f6ba84bb3bc0e86c24dab6b5
Merge pull request #1889 from ahardin-rh/sysconfig-files

Bug 1296927, added specific sysconfig files

Note You need to log in before you can comment on or make changes to this bug.