Bug 1296958 - UI: Toolbar buttons should not be there on Log Depot settings edit form screen
UI: Toolbar buttons should not be there on Log Depot settings edit form screen
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Aparna Karve
Milan Falešník
: ZStream
Depends On: 1221822
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 09:36 EST by Chris Pelland
Modified: 2016-02-10 10:31 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1221822
Environment:
Last Closed: 2016-02-10 10:31:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2016-01-08 09:36:47 EST
+++ This bug was initially created as a clone of Bug #1221822 +++

Description of problem: Toolbar buttons should not be there on Log Depot settings edit form screen


Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1. Go to Configure/Configuration/Diagnostics/Collect Logs
2. Press Edit Log Depot settings button
3. Toolbar buttons should not be visible on edit screen.

Actual results: Toolbar buttons are visible on edit screen


Expected results: Toolbar should not be there while user is editing Log Depot settings.


Additional info:

--- Additional comment from CFME Bot on 2016-01-05 15:46:14 EST ---

https://github.com/ManageIQ/manageiq/pull/6048

--- Additional comment from CFME Bot on 2016-01-07 18:10:59 EST ---

New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/365a18ea196826794171760a09d6020f78e34d4e

commit 365a18ea196826794171760a09d6020f78e34d4e
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Tue Jan 5 12:10:50 2016 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Tue Jan 5 12:32:30 2016 -0800

    Do not render toolbar when edit is clicked in log collection
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1221822

 app/controllers/ops_controller.rb             |  9 +++++---
 app/controllers/ops_controller/diagnostics.rb |  2 ++
 spec/controllers/ops_controller_spec.rb       | 31 +++++++++++++++++++++++++++
 3 files changed, 39 insertions(+), 3 deletions(-)

--- Additional comment from CFME Bot on 2016-01-08 04:46:58 EST ---

https://github.com/ManageIQ/manageiq/pull/6062

--- Additional comment from CFME Bot on 2016-01-08 04:47:02 EST ---

Detected commit referencing this ticket while ticket status is POST.
Comment 1 CFME Bot 2016-01-08 14:02:42 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c6a5fc833ef11c602c40d846d118dffb961fe8a4

commit c6a5fc833ef11c602c40d846d118dffb961fe8a4
Merge: 43dda14 0e21041
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Jan 8 13:42:14 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Jan 8 13:42:14 2016 -0500

    Merge branch 'bz1296958_dont_render_tb_on_edit' into '5.5.z'
    
    Do not render toolbar when edit is clicked in log collection
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296958
    
    Clean cherry-pick
    Upstream PR - https://github.com/ManageIQ/manageiq/pull/6048
    
    See merge request !688

 app/controllers/ops_controller.rb             |  9 +++++---
 app/controllers/ops_controller/diagnostics.rb |  2 ++
 spec/controllers/ops_controller_spec.rb       | 31 +++++++++++++++++++++++++++
 3 files changed, 39 insertions(+), 3 deletions(-)
Comment 2 CFME Bot 2016-01-08 14:02:46 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=0e210419ffd5dda86304e4dd2a0fbe97cedbc9fa

commit 0e210419ffd5dda86304e4dd2a0fbe97cedbc9fa
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Tue Jan 5 12:10:50 2016 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Fri Jan 8 06:58:58 2016 -0800

    Do not render toolbar when edit is clicked in log collection
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296958

 app/controllers/ops_controller.rb             |  9 +++++---
 app/controllers/ops_controller/diagnostics.rb |  2 ++
 spec/controllers/ops_controller_spec.rb       | 31 +++++++++++++++++++++++++++
 3 files changed, 39 insertions(+), 3 deletions(-)
Comment 4 Milan Falešník 2016-01-18 10:49:38 EST
VErified in 5.5.2.1, the toolbar buttons are not visible during editing.
Comment 5 errata-xmlrpc 2016-02-10 10:31:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.