Bug 1296972 - memory leak in 4.3.3.fc23 and 4.4-rc8.rawhide
memory leak in 4.3.3.fc23 and 4.4-rc8.rawhide
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 10:20 EST by Thorsten Leemhuis
Modified: 2016-02-09 11:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1297188 (view as bug list)
Environment:
Last Closed: 2016-02-09 11:11:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'fpaste --sysinfo --printonly' on the system where it used to happen (16.43 KB, patch)
2016-02-03 09:40 EST, Thorsten Leemhuis
no flags Details | Diff

  None (edit)
Description Thorsten Leemhuis 2016-01-08 10:20:53 EST
Description of problem:
I'm seeing memory leaks in 4.3.3-300.fc23.x86_64 as well as in 4.4.0-0.rc8.git0.1.fc24.x86_64 and 4.4.0-0.rc8.git1.1.fc24.x86_64; 4.2.8-300.fc23.x86_64 otoh works fine. 

A minute or two after boot I see this in slabtop with 4.3.3-300.fc23.x86_64
  11900  11842  99%    0,56K    425       28      6800K skbuff_head_cache  
About 25 Minutes later a lot more memory is used already:
 125804 125764  99%    0,56K   4493       28     71888K skbuff_head_cache
From experiences with earlier boots I assume the kernel will run out of memory after a few hours and panic. The problem doesn't show up in 4.2.8-300.fc23.x86_64; with 4.4.0-0.rc8 it's a different slab-name where the memory is leaking slowly (kmalloc-256 iirc)

Additional info:
I consider this mostly a JFYI bug to say "I'm seeing a regression when going from 4.2 to 4.3" and to make tracking easier in case other see this, too. I guess it's something that is pretty specific to my configuration, as I'd assume other would have noticed the problem already (I'm seeing it only on one machine). I'll try to investigate further next week. Any hints how to find the root cause are appreciated.
Comment 1 Stuart D Gathman 2016-02-01 13:18:53 EST
This prevents f23 systems from staying up more than a few hours.  Likely a duplicate: https://bugzilla.redhat.com/show_bug.cgi?id=1303270

The network DoS is interesting twist for the OOM panic
Comment 2 Stuart D Gathman 2016-02-01 13:29:08 EST
This prevents f23 systems from staying up more than a few hours.  Likely a duplicate: 

https://bugzilla.redhat.com/show_bug.cgi?id=1303270

The network DoS is interesting twist for the OOM panic

Could you post fpaste --sysinfo --printonly  ?

Not everyone sees this leak, and the rate varies among those who do.
Comment 3 Josh Boyer 2016-02-03 09:29:44 EST
Thorsten, what kind of machine is this and what modules are loaded?  Also, is this using ethernet for networking or wifi?
Comment 4 Thorsten Leemhuis 2016-02-03 09:40 EST
Created attachment 1120802 [details]
'fpaste --sysinfo --printonly' on the system where it used to happen

(In reply to Stuart D Gathman from comment #2)
> Could you post fpaste --sysinfo --printonly  ?
here it is
Comment 5 Thorsten Leemhuis 2016-02-03 09:45:07 EST
(In reply to Josh Boyer from comment #3)
> Thorsten, what kind of machine is this and what modules are loaded?
I just attached some infos.

> Also, is this using ethernet for networking or wifi?

It's a desktop machine connected to the ethernet. But it has a wifi chip connected via USB.

Problem is: I haven't seen the problem since some time (I think it was around the time when 4.3 got into updates proper for f23). I'm not totally sure, but it seems to me that I changed something in the configuration that made it vanish, as it suddenly was gone on kernels where it iirc had shown up earlier. But I'm not totally sure and I have no idea what change might be responsible. :-/
Comment 6 Stuart D Gathman 2016-02-09 10:58:47 EST
The USB Wifi was the issue.  This scratch build fixes the USB Wifi leak:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12806302

Upstream problem description:
https://bugzilla.redhat.com/show_bug.cgi?id=1303270#c36
Comment 7 Josh Boyer 2016-02-09 11:11:59 EST
I'm going to close this report out then.  Thorsten, if you can recreate it at some point, please reopen.

Note You need to log in before you can comment on or make changes to this bug.