Bug 1296980 - RFE - Enforce Tag Visibility on Cloud Stacks
RFE - Enforce Tag Visibility on Cloud Stacks
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Šimon Lukašík
Matouš Mojžíš
appliance:tag
: FutureFeature
: 1292726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 10:37 EST by Ramesh A
Modified: 2016-06-29 11:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.4
Doc Type: Enhancement
Doc Text:
There was a feature request to enforce tag visibility on Cloud Stacks. Previously, the available stacks were displayed regardless of the tagging. With this release, Cloud Stacks are displayed only if tagged.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2016-01-08 10:37:41 EST
Description of problem:
Tag Visibility on Cloud Stacks is not implemented at the moment

Version-Release number of selected component (if applicable):
5.4.4.2.20151130143928_89a28ce

How reproducible:
Very

Steps to Reproduce:
1. Create a new group by enabling a checkbox in "My Company Tags" (say Service Level/Gold)
2. Create a new user with the above role
3. Login as this user and navigate to Cloud ==> Staks

Actual results:
Displays the available stacks nevertheless of the tagging

Expected results:
Should display only if it is tagged

Additional info:
Comment 1 Ramesh A 2016-01-08 10:38:22 EST
This issue is also seen in 5.5.2.0.20151219144653_653c0d4
Comment 3 Šimon Lukašík 2016-04-13 08:03:05 EDT
Nice catch Ramesh! I can reproduce this on upstream.
Comment 5 CFME Bot 2016-04-15 11:30:43 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/4f705d63d92a37b17e6d6bb6a0b02991ae0db8bd

commit 4f705d63d92a37b17e6d6bb6a0b02991ae0db8bd
Author:     Šimon Lukašík <isimluk@fedoraproject.org>
AuthorDate: Thu Apr 14 13:48:29 2016 +0200
Commit:     Šimon Lukašík <isimluk@fedoraproject.org>
CommitDate: Thu Apr 14 13:49:09 2016 +0200

    Show OrchestrationStacks only for authorized.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296980

 app/models/rbac.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 6 Matouš Mojžíš 2016-04-27 10:34:02 EDT
Verified in 5.6.0.4-beta2.3.20160421172650_719e256.
I am not able to see Orchestration Stacks, when I set tag to group different one, than stack has and when I set tag to user and don't set any tag to stack, then I can't see it anyway.
Comment 7 Šimon Lukašík 2016-05-17 07:22:30 EDT
*** Bug 1292726 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2016-06-29 11:26:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.