This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297058 - RFE: Please add a means of loading and using plugins to the dnf API
RFE: Please add a means of loading and using plugins to the dnf API
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 16:59 EST by David Shea
Modified: 2016-06-25 18:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 17:09:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shea 2016-01-08 16:59:34 EST
Description of problem:
Currently plugins are only used when dnf is run through the CLI command, and there is no documented way to load or run plugins from python code. A means of using plugins from non-CLI code is necessary in order for plugins, in particular langpacks, to be used during anaconda installs. 

Version-Release number of selected component (if applicable):
python3-dnf-1.1.5-1.fc24.noarch
Comment 1 Honza Silhan 2016-01-11 08:23:26 EST
So far we put the shared code of plugins into dnfpluginscorelib.
Comment 2 David Shea 2016-01-11 10:09:01 EST
Isn't that more for code used by plugins? I'm not trying to write a plugin. I want to use existing plugins. As far as I can tell, the various calls to base.plugins.* in dnf/cli/cli.py and dnf/cli/main.py are what need to happen, but base.plugins and conf.plugins are not part of the API, and I have been having trouble figuring out what needs to happen where in anaconda since these methods are not documented.
Comment 3 Honza Silhan 2016-01-12 08:46:32 EST
Is there any plugin aside from langpacks you would like to call from Python API?
Comment 4 David Shea 2016-01-12 09:24:17 EST
(In reply to Jan Silhan from comment #3)
> Is there any plugin aside from langpacks you would like to call from Python
> API?

In Fedora, no. In RHEL, once everything gets to that point, probably. This could also be relevant to creators of spins and remixes, since yum was able to modify the packaging behavior (for all use cases) by including plugins.
Comment 5 Honza Silhan 2016-02-22 17:09:09 EST
This report was about Anaconda supporting langpacks in DNF backend. The new guideline for langpacks using rich and weak dependencies of RPM will be effective soon [1] and Anaconda has the support already [2].

When another use case come up, feel free to reopen.

[1] https://fedorahosted.org/fpc/ticket/593#comment:18
[2] https://github.com/rhinstaller/anaconda/pull/484

Note You need to log in before you can comment on or make changes to this bug.