Bug 1297128 - (Enhancement) Enable touchpad tapping on startup
(Enhancement) Enable touchpad tapping on startup
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-libinput (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-09 11:17 EST by HotMusicFan
Modified: 2016-01-11 06:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-10 18:49:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description HotMusicFan 2016-01-09 11:17:38 EST
Hello! :)

There is one small issue which persists since many versions of Fedora and it exists independently from the DE - tapping with the touchpad is disabled at the startup and when the user should log in (GDM, SDDM for example) - he must either press enter or press the login button by pressing the hardware buttons below the touchpad. This issue also exists when the user starts Fedora for test or for installation from the live images - he should go to 'settings' and to enable the touchpad first. It will be easier if this feature is enabled by default.
I don't know if xorg-x11-drv-libinput is the right component to file a bug against so please excuse me if I'm wrong.
Comment 1 Peter Hutterer 2016-01-10 18:49:50 EST
sorry, will remain disabled. see the first section here:

http://wayland.freedesktop.org/libinput/doc/latest/tapping.html
Comment 2 HotMusicFan 2016-01-11 06:31:04 EST
"if you don't know that tapping is a thing (or enabled by default), you get spurious button events that make the desktop feel buggy."
Well, my respects to you but I don't think that the average user is so dumb.
Comment 3 HotMusicFan 2016-01-11 06:37:32 EST
Another aspect of the problem is that even when the user enables tapping in the 'initial configuration' that he makes, tapping works in the desktop session but remains disabled on the login managers (GDM, SDDM, etc.) which is not so relevant.
For example this issue does not exist in another distributions.

Note You need to log in before you can comment on or make changes to this bug.