Bug 1297131 - Compiler ABI mismatch
Compiler ABI mismatch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compat-wxGTK3-gtk2 (Show other bugs)
22
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-09 12:02 EST by Epifanov Ivan
Modified: 2016-01-09 14:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-09 14:33:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Epifanov Ivan 2016-01-09 12:02:34 EST
Currently, building anything with wxGTK3 produces error on launch:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).


Because wxGTK3 is built with older gcc version, than currently available, and because of strict check in wxGTK3.

This was fixed for wxGTK (see https://bugzilla.redhat.com/show_bug.cgi?id=1200611), but never for wxGTK3.
Comment 1 Jeremy Newton 2016-01-09 13:11:58 EST
Was this not fixed with wxGTK3-3.0.2-12.fc24?

http://koji.fedoraproject.org/koji/buildinfo?buildID=708387

I just rebuilt wxGTK3 last week, is there a compile option that I'm missing here?
Comment 2 Epifanov Ivan 2016-01-09 13:49:43 EST
Oh, sorry, just realized i've reported it against rawhide.
That's actually on f22 with wxGTK3-3.0.2-11

That's still strange, as it should've been fixed:
Thu May 28 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 3.0.2-6
- Don't abort on ABI check, backport from wxGTK


So i did some more digging, and looks like that's problem in compat-wxGTK3-gtk2
Which was fixed in latest release, but, sadly, it's available only for 23/rawhide.
Sorry for the confusion.
Comment 3 Epifanov Ivan 2016-01-09 14:33:41 EST
Looks like nothing depends on compat-wxGTK3-gtk2, so i'll just rebuild it locally and will patiently wait for updates in repos.

Note You need to log in before you can comment on or make changes to this bug.