Bug 1297185 - [abrt] ibus: bus_dbus_impl_name_owner_changed(): ibus-daemon killed by SIGABRT
[abrt] ibus: bus_dbus_impl_name_owner_changed(): ibus-daemon killed by SIGABRT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:66a116a4eb17e5001efb611047b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 06:35 EST by sergio agnes
Modified: 2016-06-15 00:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 00:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (20.11 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: cgroup (259 bytes, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: core_backtrace (9.24 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: dso_list (2.82 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: environ (527 bytes, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: maps (13.50 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: mountinfo (3.14 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: open_fds (1.38 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: proc_pid_status (1.17 KB, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details
File: var_log_messages (315 bytes, text/plain)
2016-01-10 06:35 EST, sergio agnes
no flags Details

  None (edit)
Description sergio agnes 2016-01-10 06:35:32 EST
Description of problem:
0)There are on my system two DE: Gnome and Cinnamon and one user.
1) Exit from Cinnamon Session and enter on Gnome session with the same user.
2) Appared "Oops, ......."

Version-Release number of selected component:
ibus-1.5.11-2.fc24

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
crash_function: bus_dbus_impl_name_owner_changed
executable:     /usr/bin/ibus-daemon
global_pid:     2870
kernel:         4.4.0-0.rc6.git1.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #4 bus_dbus_impl_name_owner_changed at dbusimpl.c:1243
 #9 bus_name_service_remove_owner at dbusimpl.c:457
 #10 bus_dbus_impl_connection_destroy_cb at dbusimpl.c:1648
 #15 ibus_object_dispose at ibusobject.c:135
 #17 ffi_call_unix64 at ../src/x86/unix64.S:76
 #18 ffi_call at ../src/x86/ffi64.c:525
 #19 g_cclosure_marshal_generic at gclosure.c:1490
 #24 emit_closed_in_idle at gdbusconnection.c:1357
 #29 bus_server_run at server.c:143

Potential duplicate: bug 890645
Comment 1 sergio agnes 2016-01-10 06:35:37 EST
Created attachment 1113272 [details]
File: backtrace
Comment 2 sergio agnes 2016-01-10 06:35:39 EST
Created attachment 1113273 [details]
File: cgroup
Comment 3 sergio agnes 2016-01-10 06:35:40 EST
Created attachment 1113274 [details]
File: core_backtrace
Comment 4 sergio agnes 2016-01-10 06:35:42 EST
Created attachment 1113275 [details]
File: dso_list
Comment 5 sergio agnes 2016-01-10 06:35:43 EST
Created attachment 1113276 [details]
File: environ
Comment 6 sergio agnes 2016-01-10 06:35:44 EST
Created attachment 1113277 [details]
File: limits
Comment 7 sergio agnes 2016-01-10 06:35:46 EST
Created attachment 1113278 [details]
File: maps
Comment 8 sergio agnes 2016-01-10 06:35:48 EST
Created attachment 1113279 [details]
File: mountinfo
Comment 9 sergio agnes 2016-01-10 06:35:49 EST
Created attachment 1113280 [details]
File: namespaces
Comment 10 sergio agnes 2016-01-10 06:35:50 EST
Created attachment 1113281 [details]
File: open_fds
Comment 11 sergio agnes 2016-01-10 06:35:52 EST
Created attachment 1113282 [details]
File: proc_pid_status
Comment 12 sergio agnes 2016-01-10 06:35:53 EST
Created attachment 1113283 [details]
File: var_log_messages
Comment 13 fujiwara 2016-01-11 21:46:13 EST
I cannot reproduce your backtrace.
Are you still able to see your backtrace?

(In reply to sergio agnes from comment #1)
> Created attachment 1113272 [details]
> File: backtrace

#0  0x00007f4db8c43618 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007f4db8c4521a in __GI_abort () at abort.c:89
#2  0x00007f4db9261f35 in g_assertion_message (domain=domain@entry=0x560430f7db3a "IBUS", file=file@entry=0x560430f7dfe6 "dbusimpl.c", line=line@entry=1243, func=func@entry=0x560430f7e8a0 <__func__.26124> "bus_dbus_impl_name_owner_changed", message=message@entry=0x560433238120 "assertion failed: (new_owner != NULL)") at gtestutils.c:2429
#3  0x00007f4db9261fca in g_assertion_message_expr (domain=domain@entry=0x560430f7db3a "IBUS", file=file@entry=0x560430f7dfe6 "dbusimpl.c", line=line@entry=1243, func=func@entry=0x560430f7e8a0 <__func__.26124> "bus_dbus_impl_name_owner_changed", expr=expr@entry=0x560430f7e104 "new_owner != NULL") at gtestutils.c:2452
#4  0x0000560430f6d966 in bus_dbus_impl_name_owner_changed (dbus=0x5604331d2040, connection=<optimized out>, name=0x560433237830 "org.freedesktop.IBus.Panel", old_owner=0x56043331cf60 ":1.3", new_owner=0x0) at dbusimpl.c:1243
#5  0x00007f4db953c995 in g_closure_invoke (closure=closure@entry=0x560433181120, return_value=return_value@entry=0x0, n_param_values=5, param_values=param_values@entry=0x7ffd954015d0, invocation_hint=invocation_hint@entry=0x7ffd95401550) at gclosure.c:804
#6  0x00007f4db954f04c in signal_emit_unlocked_R (node=node@entry=0x560433180a80, detail=detail@entry=0, instance=instance@entry=0x5604331d2040, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7ffd954015d0) at gsignal.c:3559
#7  0x00007f4db95584c0 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7ffd954017f0) at gsignal.c:3385
#8  0x00007f4db955888f in g_signal_emit (instance=instance@entry=0x5604331d2040, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3441
#9  0x0000560430f6bc43 in bus_name_service_remove_owner (service=service@entry=0x560433239d40, owner=owner@entry=0x560433239d50, dbus=dbus@entry=0x5604331d2040) at dbusimpl.c:457
#10 0x0000560430f6bfd4 in bus_dbus_impl_connection_destroy_cb (connection=0x7f4d98002310, dbus=0x5604331d2040) at dbusimpl.c:1648
#11 0x00007f4db953c995 in g_closure_invoke (closure=0x56043317ed00, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7ffd95401b10, invocation_hint=invocation_hint@entry=0x7ffd95401a90) at gclosure.c:804
#12 0x00007f4db954f511 in signal_emit_unlocked_R (node=node@entry=0x560433179a10, detail=detail@entry=0, instance=instance@entry=0x7f4d98002310, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7ffd95401b10) at gsignal.c:3629
#13 0x00007f4db95584c0 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7ffd95401cd0) at gsignal.c:3385
#14 0x00007f4db955888f in g_signal_emit (instance=instance@entry=0x7f4d98002310, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3441
#15 0x00007f4db9b21d12 in ibus_object_dispose (obj=0x7f4d98002310) at ibusobject.c:135
#16 0x00007f4db95433d9 in g_object_run_dispose (object=0x7f4d98002310) at gobject.c:1082
Comment 14 sergio agnes 2016-01-13 11:35:28 EST
Hi, fujiwara,
backtrace now is not reproducible because it seems that after an upgrade abrt not recognize the error. "Oops, ......" disappeared. 
Going from cinnamon-session to gnome-session with the same user there are no more errors. 
Just as well.
I do not know why, but now everything seems to work regularly. 
Thank you.
Ciao :)
Sergio
Comment 15 Jan Kurik 2016-02-24 09:15:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 16 fujiwara 2016-06-15 00:34:27 EDT
Please comment here again if you will find the reproducing steps.

Note You need to log in before you can comment on or make changes to this bug.