Bug 1297189 - dnf history undo not possible if package is missing
dnf history undo not possible if package is missing
Status: CLOSED DUPLICATE of bug 1218415
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 06:56 EST by František Zatloukal
Modified: 2016-01-11 08:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 08:33:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description František Zatloukal 2016-01-10 06:56:07 EST
Description of problem:
dnf is not able to perform history undo if some package from transaction to be undone is not installed or installed in different version.

Version-Release number of selected component (if applicable):
dnf-1.1.5

How reproducible:
Always

Steps to Reproduce:
1.Do some transaction
2.Upgrade or remove a package installed by transaction in step 1
3.dnf history undo last

Actual results:
Altered package blocks undo operation

Expected results:
dnf should be able to perform incomplete undo operation.
Comment 1 Honza Silhan 2016-01-11 08:33:01 EST
you can workaround this problem by setting `keepcache=1` in `/etc/dnf/dnf.conf`

*** This bug has been marked as a duplicate of bug 1218415 ***

Note You need to log in before you can comment on or make changes to this bug.