Bug 129719 - Upstream indic translations need to be incorporated into OOo packages
Upstream indic translations need to be incorporated into OOo packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: i18n
Depends On:
Blocks: Indic 137149
  Show dependency treegraph
 
Reported: 2004-08-11 22:33 EDT by Jatin Nansi
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: openoffice.org-1.1.2-18.6.EL4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 01:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gu_IN translation with euro translation (187.89 KB, image/png)
2004-11-30 03:20 EST, Leon Ho
no flags Details
ta_IN translations mixed with euro translations (166.05 KB, image/png)
2004-11-30 03:22 EST, Leon Ho
no flags Details

  None (edit)
Description Jatin Nansi 2004-08-11 22:33:18 EDT
Description of problem:
The upstream translations for the 5 indic languages (hi, pa, ta, gu,
bn) need to be incorporated into our packages. 

Version-Release number of selected component (if applicable):
1.1.1-6

How reproducible:
Every time

Steps to Reproduce:
1. Start openoffice.org in any indic locale.
2.
3.
  
Actual results:
openoffice.org UI is in English

Expected results:
For indic locales, the UI should be in the corresponding language.

Additional info:
The translations for hi, ta, bn & gu are available, pa translations
have not yet started. 
More information on each language is available on
http://<lang_code>.openoffice.org for the respective language.
The translations are often on other sites, links available from the
URL above.
Comment 1 Dan Williams 2004-09-16 22:17:34 EDT
If they are available for OOo 1.1.x then they should get into FC3.  If
they are only for 2.0, we are out of luck for the 1.1.x series (can't
backport languages without a bunch of work).
Comment 2 Sarah Wang 2004-09-19 23:09:40 EDT
Hi Jatin,

Since it's impossible for us to tell from
http://<lang_code>.openoffice.org weather OOo 1.1.x translations for
hi, ta, bn & gu are available or not, would you pls investigate it
furthur?

Thanks,
Sarah
Comment 3 Dan Williams 2004-09-20 00:14:06 EDT
Which indic-type languages do we need?  OOo has the "hindi" language
tag used for translations at this point, but I'm not sure how good the
coverage is.

All files that contain translated strings are *.src files.  Two good
tools to use to examine the sources are:

http://ooo.ximian.com (and use the LXR on the right side)
http://sw.openoffice.org/source/browse/sw/sw/ (direct link to Writer
source code)
Comment 4 Jatin Nansi 2004-09-20 01:40:24 EDT
Hi all,

I am sorry i took so long to respond. The URL below contains the
translated glossaries for hindi and tamil. 

http://www.ncb.ernet.in/bharateeyaoo/index1.html
Scroll down till you reach the Glossaries section. There are several
other related links on same the page.

The bengali and gujarati glossaries have been translated, but haven't
yet been tested. They are also not publicly available (no JCA), tho
they are available to us. Should we use the glossaries then?

Punjabi glossary has not been translated. Thus should the pa team
translate OOo 1.1 or 2? Which version would be better considering the
schedules for OOo 2 and RHEL?
Comment 5 Jatin Nansi 2004-09-23 06:29:20 EDT
The gujarati translations are available here:
http://gu.openoffice.org/servlets/ProjectDocumentList?folderID=361&expandFolder=361&folderID=374
Comment 6 Jatin Nansi 2004-10-08 03:11:27 EDT
Status update: Hindi translations are in; however not for other four
indic languages.
Comment 7 Dan Williams 2004-11-05 11:42:26 EST
I can get the Hindi translation, but the other two aren't in .gsi file
format...  do you have any idea how to convert the others?

gsi file format looks like this and includes the location where the
string is supposed to actually go:
basctl  source\basicide\basidesh.src    0       string 
RID_STR_FILTER_ALLFILES                         0       1       <All>
         20040719 07:34:35

Comment 8 Dan Williams 2004-11-05 11:43:24 EST
Hmm, I mean, I can get the Gujarati translation, but teh Hindi
translation is one of the ones that's not in .gsi format.
Comment 9 Jatin Nansi 2004-11-06 08:06:29 EST
umm... since ooo in RHEL4B2 is already available in hindi, i guess you
mean that:
1. hindi is available in .gsi format and 
2. you need the gujarati and tamil translations in .gsi format?
Comment 10 Dan Williams 2004-11-07 09:47:08 EST
No, the gujarati translation from:

http://gu.openoffice.org/servlets/ProjectDocumentList?folderID=361&expandFolder=361&folderID=374

IS in .gsi format, which is what I need.  The other two (Hindi and
Tamil) aren't in a format I can use...

---------------------------
I am sorry i took so long to respond. The URL below contains the
translated glossaries for hindi and tamil. 

http://www.ncb.ernet.in/bharateeyaoo/index1.html
Scroll down till you reach the Glossaries section. There are several
other related links on same the page.
---------------------------

On that page, there are glossary files for Hindi and Tamil.  If you
say that the current OOo in RHEL4 _has_ a good Hindi translation, the
thats great.  I still can't use the Tamil translation though until its
in a .gsi file format...

Dan
Comment 11 Dan Williams 2004-11-09 18:38:14 EST
Jatin: I did get a Tamil .gsi file a while back in email from you, on
Sept. 20, titled "Tamil openoffice.org translation issues".  I will
incorporate that file into the next build (-12).

So we still need hi + bn translations.
Comment 12 Jatin Nansi 2004-11-10 07:23:03 EST
As of now, only hi, tn and gu are translated for OOo. 
With hindi already in the package, and .gsi files for tn and gu found,
you now have all available translations.
Comment 13 Jatin Nansi 2004-11-10 07:25:05 EST
of course, i meant ta (for tamil) and not tn in the comment above.
Comment 14 Dan Williams 2004-11-23 13:58:46 EST
The languages were not getting merged correctly.  I have a fix for
this which I will build into the next package.
Comment 15 Lawrence Lim 2004-11-30 02:48:06 EST
Tested with openoffice.org-1.1.2-14.6.EL4.

bn_IN: not translated
gu_IN: majority of the strings in the menu are translated.
hi_IN: good
pa_IN: not translated
ta_IN: good
Comment 16 Leon Ho 2004-11-30 03:09:32 EST
We still see a UI bug on gu_IN and ta_IN at bug 137954
Comment 17 Leon Ho 2004-11-30 03:20:20 EST
Created attachment 107607 [details]
gu_IN translation with euro translation

Dan, please have a look into this problem. Currently if gu_IN translation is
not available, euro translations will be used (instead of falling back to
english).
Comment 18 Leon Ho 2004-11-30 03:22:26 EST
Created attachment 107608 [details]
ta_IN translations mixed with euro translations
Comment 19 Dan Williams 2004-12-07 22:56:17 EST
A fix for this problem (replacing untranslated strings with English
instead of German) will be available in 1.1.2-17 and higher.
Comment 21 Akira TAGOH 2004-12-10 11:42:06 EST
Tested with 1.1.2-17.6.EL4.

bn_IN: not translated, but no empty square.
gu_IN: majority of strings are translated and no empty square.
hi_IN: few strings in Tools and Help isn't translated, but no empty
square.
pa_IN: not translated, but no empty square.
ta_IN: few strings in File isn't translated, but no empty square.
Comment 22 Akira TAGOH 2004-12-10 14:42:29 EST
Ok, I think the program bugs has been gone. it's time to change the
severity to translation then.
Comment 23 Dan Williams 2004-12-12 21:25:46 EST
Ok, the problem with the gu_IN translation is that the .gsi file is
not the correct format, most lines are missing a required tab
somewhere in them (there must be 15 tabs on each line, many have only
14).  There's actually a defined format for the .gsi files, and they
technically have 16 fields or something, but not all are used, so it
would be easy to forget a tab in there somewhere.

I'll have to hack up the translation merge program to accept this odd
.gsi file format once I figure out where the missing tab is and if its
consistently missing in the same place.

I'll be able to get this in for 1.1.2-18 which should be our RHEL4 GA
final build.
Comment 24 Dan Williams 2004-12-13 00:09:30 EST
A patch which accepts lines with between 13 and 16 fields inclusive
will get added to 1.1.2-18.  That should take care of the majority of
cases, though I see that the gu_IN translations are majorly broken in
this area (the spread of fields is from 12 - 20, which is utter crack.
 Somebody probably removed/added tabs to make it look pretty in a text
editor, but of course that breaks transex3).  It should make the
translation much more complete at the cost of a few string mixups.
Comment 26 Dan Williams 2004-12-15 09:31:42 EST
1.1.2-18.6.EL4 is in dist-4E
Comment 27 Lawrence Lim 2004-12-16 01:05:34 EST
Confirmed fixed in 1.1.2-18.6.EL4. 

bn_IN: Untranslated
gu_IN: Mostly translated and the european strings are gone
hi_IN: Mostly translated
pa_IN: Untranslated
ta_IN: Mostly translated and the european strings are gone.

Note You need to log in before you can comment on or make changes to this bug.