This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297195 - no-mtab (-n) mount option ignore next mount option
no-mtab (-n) mount option ignore next mount option
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
: Triaged
Depends On:
Blocks: 1297209
  Show dependency treegraph
 
Reported: 2016-01-10 07:15 EST by Niels de Vos
Modified: 2016-06-16 09:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1297209 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2016-01-10 07:15:18 EST
Description of problem:
The -n option does not take any arguments. It seems like this shift is removing the next option.

Version-Release number of selected component (if applicable):
all

How reproducible:
100%

Steps to Reproduce:
1. mount -t glusterfs -n -o ro storage.example.com:/volume /mnt
2. verify that the volume is mounted read-only (it is not)

Actual results:
The option after "-n" is skipped, if this is the "-o .." option, all mount options are ignored.

Expected results:
Mounting with "-n" should not affect any of the options it follows.

Additional info:
Comment 1 Vijay Bellur 2016-01-10 07:15:44 EST
REVIEW: http://review.gluster.org/12988 (no-mtab (-n) mount option ignore next mount option) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 2 Vijay Bellur 2016-01-10 14:28:46 EST
COMMIT: http://review.gluster.org/12988 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 9e7cd9456532caa7b255978b4b435418c04e0db9
Author: James Augustine <jcaugust81@gmail.com>
Date:   Wed Dec 16 14:56:11 2015 -0600

    no-mtab (-n) mount option ignore next mount option
    
    The -n option does not take any arguments. It seems like this shift is
    removing the next option. On my CentOS 7 system, automount calls
    mount.glusterfs with the parameters:
     host:/volume /mountpoint -n -o rw,acl,_netdev
    This causes the -o option to be siliently ignored.
    
    Change-Id: Ice3c877f6ab346b04292e3dfed968d04d15077a5
    BUG: 1297195
    Signed-off-by: James Augustine <jcaugust81@gmail.com>
    Reviewed-on: http://review.gluster.org/12988
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:54:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.