Bug 1297229 - [abrt] systemd: __memcpy_sse2_unaligned(): systemd-journald killed by SIGABRT
[abrt] systemd: __memcpy_sse2_unaligned(): systemd-journald killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1300212
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:870ed33532787647e0e8a701a59...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 16:51 EST by Milan Bouchet-Valat
Modified: 2016-01-25 06:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 03:29:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.92 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: cgroup (222 bytes, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: core_backtrace (3.61 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: dso_list (1.15 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: environ (174 bytes, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: maps (6.65 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: mountinfo (3.61 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: open_fds (15.08 KB, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: proc_pid_status (1001 bytes, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-01-10 16:51 EST, Milan Bouchet-Valat
no flags Details

  None (edit)
Description Milan Bouchet-Valat 2016-01-10 16:51:28 EST
Description of problem:
When this happens, the whole GNOME session is suddenly closed.

Version-Release number of selected component:
systemd-222-12.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-journald
crash_function: __memcpy_sse2_unaligned
executable:     /usr/lib/systemd/systemd-journald
global_pid:     475
kernel:         4.3.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __memcpy_sse2_unaligned at ../sysdeps/x86_64/multiarch/memcpy-sse2-unaligned.S:37
 #1 memcpy at /usr/include/bits/string3.h:53
 #2 journal_file_append_entry_internal.constprop.119 at src/journal/journal-file.c:1356
 #3 journal_file_append_entry.constprop.111 at src/journal/journal-file.c:1450
 #4 write_to_journal at src/journal/journald-server.c:513
 #5 dispatch_message_real.lto_priv.238 at src/journal/journald-server.c:820
 #6 server_dispatch_message at src/journal/journald-server.c:918
 #7 stdout_stream_log at src/journal/journald-stream.c:266
 #8 stdout_stream_line.lto_priv.169 at src/journal/journald-stream.c:364
 #9 stdout_stream_scan at src/journal/journald-stream.c:394
Comment 1 Milan Bouchet-Valat 2016-01-10 16:51:35 EST
Created attachment 1113392 [details]
File: backtrace
Comment 2 Milan Bouchet-Valat 2016-01-10 16:51:36 EST
Created attachment 1113393 [details]
File: cgroup
Comment 3 Milan Bouchet-Valat 2016-01-10 16:51:38 EST
Created attachment 1113394 [details]
File: core_backtrace
Comment 4 Milan Bouchet-Valat 2016-01-10 16:51:39 EST
Created attachment 1113395 [details]
File: dso_list
Comment 5 Milan Bouchet-Valat 2016-01-10 16:51:40 EST
Created attachment 1113396 [details]
File: environ
Comment 6 Milan Bouchet-Valat 2016-01-10 16:51:42 EST
Created attachment 1113397 [details]
File: limits
Comment 7 Milan Bouchet-Valat 2016-01-10 16:51:43 EST
Created attachment 1113398 [details]
File: maps
Comment 8 Milan Bouchet-Valat 2016-01-10 16:51:45 EST
Created attachment 1113399 [details]
File: mountinfo
Comment 9 Milan Bouchet-Valat 2016-01-10 16:51:46 EST
Created attachment 1113400 [details]
File: namespaces
Comment 10 Milan Bouchet-Valat 2016-01-10 16:51:49 EST
Created attachment 1113401 [details]
File: open_fds
Comment 11 Milan Bouchet-Valat 2016-01-10 16:51:50 EST
Created attachment 1113402 [details]
File: proc_pid_status
Comment 12 Milan Bouchet-Valat 2016-01-10 16:51:53 EST
Created attachment 1113403 [details]
File: var_log_messages
Comment 13 Milan Bouchet-Valat 2016-01-10 17:02:10 EST
Upstream said at https://github.com/systemd/systemd/issues/1015 that systemd 223 included some journal-related changes which might fix this bug. Would it be possible to update to that version, or to backport the changes?
Comment 15 Milan Bouchet-Valat 2016-01-11 13:13:26 EST
I would be happy to test a package for a while if it can help.
Comment 16 Jan Synacek 2016-01-25 03:13:24 EST
To me, this looks like another duplicate of bug #1300212, but I'm going to backport the above patch anyway.
Comment 17 Jan Synacek 2016-01-25 03:29:37 EST
The patch mentioned in comment 14 is already present in F23.

*** This bug has been marked as a duplicate of bug 1300212 ***
Comment 18 Milan Bouchet-Valat 2016-01-25 04:19:00 EST
OK. It really looks like this timeout is a cause of trouble for many people...
Comment 19 Jan Synacek 2016-01-25 06:08:53 EST
You can check https://bodhi.fedoraproject.org/updates/FEDORA-2016-3d6ff41417, which contains a batch of fixes including the timeout increase.

Note You need to log in before you can comment on or make changes to this bug.