Bug 1297260 - virt-viewer console will restore a larger window when use mouse to drag the window to minimum
virt-viewer console will restore a larger window when use mouse to drag the w...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.3
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1296878
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 21:42 EST by mxie@redhat.com
Modified: 2016-11-03 21:14 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1296878
Environment:
Last Closed: 2016-11-03 21:14:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Fabiano Fidêncio 2016-03-15 11:37:35 EDT
The 2 patches that solve this issue are:
907f8c5d3347eef95ecb6eccc7c5752093c7f5cf
c2046a2992b04fde2286c6feffdd7f4410087583
Comment 4 xiaodwan 2016-04-15 03:28:24 EDT
I can reproduce it with virt-viewer-2.0-6.el7.x86_64.

# rpm -q virt-viewer
virt-viewer-2.0-6.el7.x86_64

Then updated virt-viewer to latest virt-viewer-2.0-7.el7.x86_64 and verified with below steps again. The issue is fixed.

Steps:
1.Prepare a rhel6 guest or a rhel7 guest and use virt-viewer connect to the guest
2. Use mouse to drag the window to minimum, then virt-viewer window size will keep at 320x200 even if using mouse to drag the window to small size
3. Check the resolution of guest, the resolution should  be 320x200

So move the bug from ON_QA to VERIFIED.
Comment 6 errata-xmlrpc 2016-11-03 21:14:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.