Bug 1297263 - freecad included non-free content.
Summary: freecad included non-free content.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2016-01-11 02:59 UTC by mejiko
Modified: 2019-01-09 12:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 20:50:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mejiko 2016-01-11 02:59:23 UTC
Hello.

freecad included non-free content.

File list:

"freecad-0.15.4671/src/Gui/Icons/edit-cut.svg"
"freecad-0.15.4671/src/Mod/Mesh/Gui/Resources/icons/mesh_cut.svg"

See: https://lintian.debian.org/tags/license-problem-cc-by-nc-sa.html (freecad Section).

This files license is cc-by-nc-sa.
It is non-free.

Thanks.

Comment 1 Richard Shaw 2016-01-11 14:53:55 UTC
Has upstream been informed?

Comment 2 Tom "spot" Callaway 2016-01-12 20:50:34 UTC
These files are not CC-BY-NC-SA, I have no idea why Debian's lintian flagged them as such.

edit-cut.svg is taken from the Tango Icons theme, which was once CC-BY-SA and is now in the Public Domain:

https://github.com/FreeCAD/FreeCAD/blob/master/src/Gui/Icons/edit-cut.svg
https://commons.wikimedia.org/wiki/File:Edit-cut.svg
http://tango.freedesktop.org/Frequently_Asked_Questions#Terms_of_Use.3F

mesh_cut.svg is clearly derived from edit-cut.svg:

https://github.com/FreeCAD/FreeCAD/blob/master/src/Mod/Mesh/Gui/Resources/icons/mesh_cut.svg

There is no evidence of this file being licensed CC-BY-NC-SA, in fact, because the original work is Public Domain, their "artwork license declaration would apply", making it LGPL:

http://www.freecadweb.org/wiki/?title=FAQ#Licensing.2C_copying_and_reuse

Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.