Bug 1297284 - Too many "failed to get the inode context for the inode" errors in brick logs
Too many "failed to get the inode context for the inode" errors in brick logs
Status: CLOSED DUPLICATE of bug 1297300
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: bitrot (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
RajeshReddy
: ZStream
Depends On: 1296399 1297300
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 00:57 EST by Bhaskarakiran
Modified: 2016-09-17 10:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 02:34:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhaskarakiran 2016-01-11 00:57:03 EST
Description of problem:
=======================

A lot of bitrot error messages are seen in the brick logs.


[2016-01-09 08:10:31.194770] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode 1572c2f5-9917-423b-a987-86a7a78d342e
[2016-01-09 08:10:31.252071] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode 1572c2f5-9917-423b-a987-86a7a78d342e
[2016-01-09 08:10:31.288027] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode ba5f4b4c-2022-43c5-8d45-fa65ac8f3227
[2016-01-09 08:10:31.296192] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode b7b9d689-4b21-44eb-86c8-1c7f9f6b32ba
[2016-01-09 08:10:31.383698] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode ba5f4b4c-2022-43c5-8d45-fa65ac8f3227
[2016-01-09 08:10:31.501594] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode f7d80536-d2c1-48e0-a9de-0a7c3c55689b
[2016-01-09 08:10:31.566981] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode 9676610d-8d4b-4362-b230-6f2107050059
[2016-01-09 08:10:31.569765] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode f7d80536-d2c1-48e0-a9de-0a7c3c55689b
[2016-01-09 08:10:31.630599] E [MSGID: 116012] [bit-rot-stub.h:364:br_stub_is_bad_object] 0-disperse_vol1-bitrot-stub: failed to get the inode context for the inode 9676610d-8d4b-4362-b230-6f2107050059



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Bhaskarakiran 2016-01-11 01:12:58 EST
Version:
========
3.7.5-15


https://bugzilla.redhat.com/show_bug.cgi?id=1296048 was filed and this bitrot issue seems to be a bigger issue. 


For the bitrot issues, upsteam bug is :https://bugzilla.redhat.com/show_bug.cgi?id=1297284

Note You need to log in before you can comment on or make changes to this bug.