Bug 129729 - up2date doesn't like yum archives
up2date doesn't like yum archives
Status: CLOSED DUPLICATE of bug 129215
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: up2date-rhel3-u3
  Show dependency treegraph
 
Reported: 2004-08-12 05:04 EDT by John Haxby
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Haxby 2004-08-12 05:04:03 EDT
Description of problem:

If you configure a yum archive in /etc/sysconfig/rhn/sources for example:

   yum packages http://<hostname>/packages

and then run "up2date --dry-run --update" you'll get this backtrace:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 62, in run
  File "up2dateBatch.py", line 97, in __findPackagesToUpdate
  File "packageList.py", line 157, in addGlobs
  File "rhnPackageInfo.py", line 232, in getAvailablePackageList
  File "rhnPackageInfo.py", line 166, in availablePackageList
  File "rpcServer.py", line 304, in doCall
  File "repoDirector.py", line 20, in listPackages
  File "rpmSource.py", line 226, in listPackages
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
266, in listPackages
    hdr = rd.getHeader([name,ver,rel,epoch,arch, "0",channel['label']])
  File "repoDirector.py", line 31, in getHeader
  File "rpmSource.py", line 210, in getHeader
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
100, in getHeader
    hdr = rpmUtils.readHeaderBlob(hdrBuf)
TypeError: readHeaderBlob() takes exactly 2 arguments (1 given)


Version-Release number of selected component (if applicable):

up2date-4.2.33-1, rpm-4.2.3-1

Since this is the same version of up2date that's running on a non-beta
RHEL3 machine, it looks as though it's a compatability problem with
the two versions of RPM.   If it's because I've managed to get an
up2date from the base channel instead of the beta channel and the
problem is already resolved, please accept my apologies.
Comment 1 Adrian Likins 2004-08-17 13:59:18 EDT
this will be fixed in Update 3 (4.2.33 or higher package revisions)
Comment 2 Todd Warner 2004-08-26 19:40:19 EDT

*** This bug has been marked as a duplicate of 129215 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.