Bug 1297295 - Multi-tenancy: Able to set child tenant quota greater then parent tenant
Multi-tenancy: Able to set child tenant quota greater then parent tenant
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Libor Pichler
Aziza Karol
cfme_tenant:quota
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 01:17 EST by Aziza Karol
Modified: 2016-06-29 11:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:27:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2016-01-11 01:17:33 EST
Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.0.20151219144653_653c0d4 

How reproducible:
100%

Steps to Reproduce:
1.Navigate to configure->Access control->tenants
2.For Tenant " My Company " enforce CPU quota and set it to for ex:5
3.create a child tenant and enforce CPU quota more then the parent tenant ex:20

Actual results:
No validation message is displayed if child quota is set to greater value  then tenant quota

Expected results:
validation required

Additional info:
Comment 2 Libor Pichler 2016-01-20 04:30:17 EST
Hi Aziza,

this is ok,
'My Company' is root tenant and when you enforcing quotas for tenant which have parent tenant as root tenant, he can also have unlimited quota.

so in other words:
- Root tenant has no (unlimited) quota
- First level tenant can also have unlimited quota

thanks
Comment 3 Aziza Karol 2016-04-29 05:13:23 EDT
Marking as verified base on comment 2.

Root tenant and first level tenant can have unlimited quota.


Verified:5.6.0.4-beta2.3.20160421172650_719e256
Comment 5 errata-xmlrpc 2016-06-29 11:27:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.