Bug 1297302 - [GSS](6.2.z) jboss-cli remove hornetQ server while trying to delete a jms-queue with empty name
[GSS](6.2.z) jboss-cli remove hornetQ server while trying to delete a jms-que...
Status: CLOSED DUPLICATE of bug 1169342
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Chao Wang
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 01:52 EST by sfu@redhat.com
Modified: 2016-02-12 03:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 04:18:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sfu@redhat.com 2016-01-11 01:52:14 EST
Description of problem:
jboss-cli.sh remove hornetQ server while trying to delete a jms-queue with empty name

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.Install and start JBoss Server instance
2.connect to JBoss CLI
3.use command: /subsystem=messaging/hornetq-server=default/jms-queue=:remove()

Actual results:
hornetQ server will be removed.

Expected results:
Expected a failure, saying the queue "" doesn't exist.

Additional info:
Can reproduce with JBoss EAP 6.2 6.3 6.4
Comment 1 Chao Wang 2016-01-11 03:14:30 EST
This does not exist in EAP 6.4.5 as output:

[standalone@localhost:9999 /] /subsystem=messaging/hornetq-server=default/jms-queue=:remove()
Node type is not complete at index 54
[standalone@localhost:9999 /] quit
Node type is not complete at index 0
[standalone@localhost:9999 /] exit
Node type is not complete at index 0
[standalone@localhost:9999 /] 


This has been fixed since EAP 6.4.1, thus you can not call =:remove() to remove a nonexistent queue. However, this case exposes a CLI regression made in EAP 6.4.1 as example above which was reported in https://bugzilla.redhat.com/show_bug.cgi?id=1277320
Comment 2 Chao Wang 2016-01-11 04:18:58 EST

*** This bug has been marked as a duplicate of bug 1169342 ***

Note You need to log in before you can comment on or make changes to this bug.