Bug 1297308 - Application doesn't show the puppet-modules which are already synced/added in other org
Application doesn't show the puppet-modules which are already synced/added in...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.6
: --
Assigned To: Justin Sherrill
Sachin Ghai
http://projects.theforeman.org/issues...
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 02:22 EST by Sachin Ghai
Modified: 2017-02-23 14:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 08:31:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
puppet_module repo synced successfully but module count is 0 on UI (51.43 KB, image/png)
2016-01-11 02:27 EST, Sachin Ghai
no flags Details
CV doesn't show anything on adding the same puppet-module (44.88 KB, image/png)
2016-01-11 02:29 EST, Sachin Ghai
no flags Details
in first org, puppet-modules are visible (64.79 KB, image/png)
2016-01-11 02:29 EST, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13166 None None None 2016-04-22 12:22 EDT

  None (edit)
Description Sachin Ghai 2016-01-11 02:22:53 EST
Description of problem:
Looks like an issue with puppet-modules which are already added in other org.

First time, when you add puppet-modules from a URL and synced and add them to CV(content-view), CV clearly shows the module name and its available version. However when you use same URL to add those puppet-modules in another org, then CV does not show those modules under CV -> Puppet-module-> Add New module


Version-Release number of selected component (if applicable):
Satellite 6.1.6 compose3

How reproducible:
always

Steps to Reproduce:
1. Create a new org or select default org
2. Add a puppet repo using URL: https://omaciel.fedorapeople.org/random_puppet/
3. sync the repo, you will see one module
4. create a CV
5. add the puppet-module

6. now create another org 'testorg'
7.  Add a puppet repo using same URL as above
8. sync the repo, sync would be success, but module count is zero
9. create a CV
10. add the puppet-module - no module would be visible. 


Actual results:
on re-adding puppet modules from already synced URL in another org, wwouldnt show the puppet-modules

Expected results:
puppet-modules should be visible.

Additional info:
Comment 1 Sachin Ghai 2016-01-11 02:27 EST
Created attachment 1113513 [details]
puppet_module repo synced successfully but module count is 0 on UI
Comment 2 Sachin Ghai 2016-01-11 02:29 EST
Created attachment 1113514 [details]
CV doesn't show anything on adding the same puppet-module
Comment 3 Sachin Ghai 2016-01-11 02:29 EST
Created attachment 1113515 [details]
in first org, puppet-modules are visible
Comment 5 Jitendra Yejare 2016-01-11 02:40:57 EST
I observed the same behaviour in my setup.

The puppet module synced and added to CV in one Org is not even synced in another org. The sync shows success but the module count is 0 in second org.
Comment 6 Jitendra Yejare 2016-01-11 02:41:41 EST
I observed the same behaviour in my setup Satellite 6.1.6 #c4.

The puppet module synced and added to CV in one Org is not even synced in another org. The sync shows success but the module count is 0 in second org.
Comment 8 Oleksandr Shtaier 2016-01-12 03:24:17 EST
Issue is not specific for WebUI and can be reproduced in the same way using API directly
Comment 9 Oleksandr Shtaier 2016-01-12 03:37:48 EST
I can also confirm that issue is a regression as functionality worked completely fine on 6.1.5 for example.
Comment 10 Oleksandr Shtaier 2016-01-12 03:40:01 EST
And as everywhere mentioned - that issue is more problem of Puppet Repositories functionality rather than Content Views one, so it is necessary to concentrate attention on that, but of course, in the final result, it is necessary to verify CV part too.
Comment 11 Justin Sherrill 2016-01-12 19:45:39 EST
Created redmine issue http://projects.theforeman.org/issues/13166 from this bug
Comment 12 Bryan Kearney 2016-01-12 20:03:09 EST
Upstream bug assigned to jsherril@redhat.com
Comment 13 Bryan Kearney 2016-01-12 20:03:12 EST
Upstream bug component is Content Management
Comment 14 Bryan Kearney 2016-01-12 22:03:29 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13166 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|6f44285bf0dc4e71aa47be12496b8ecac85b648c.
Comment 16 Mike McCune 2016-01-15 11:33:06 EST
This got missed on a move to ON_QA
Comment 17 Corey Welton 2016-01-15 16:40:23 EST
Verified this in 6.1.6 compose #5

After syncing a puppet repo and uploading a puppet module to a CV in one org, and subsequently doing the same in another org (using the same repo), I was able to see the puppet module for selection/addition to CV in second org.
Comment 18 Bryan Kearney 2016-01-21 08:31:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0052

Note You need to log in before you can comment on or make changes to this bug.